Pianoteq acitivation?


I searched and did not find a topic in the forum or wiki with a step by step guide to use my registered version of Pianoteq with the Zynthian… Can someone point me to the right directions ?


Upload the binary package and after rebooting, configure your license key in the webconf.
PTQ files are pianoteq instruments. You can download some of them from your pianoteq account.


1 Like

Where do i get this binary ? Is the ’ Linux, v6.6.0, 32-bit/64-bit’ download available on Pianoteq site ?

It’s a .7z file, should i upload it compacted or should i unzip it before upload ?

And how to configure my license key correctly ?

I could not find these information on the wiki :thinking:

Upload the binary un 7z format. Follow the instrucciones from the webconf.

Tried that, but when i click on ‘Upload’ button, nothing happens.

As i’m a developer my self, i inspected the devtools and there is a JS exception happening, see te attached screen.

could you try to access the machine with the ip and not zynthian.local

1 Like

I tried again and it worked ! Now my Pianoteq is registered :smiley:

1 Like

This thing is AWESOME ! Why i don’t discovered the Zynthian before !


I have only one layer active. While playing Pianoteq using a Midi controller, i’m having glitches on the sound and a red sign with exclamation will show up and disapper on the upper right on Zynthian screen… What could it be ?

PS : Actually the red exclamation also shows up when i just turn the knobs fast, while in Pianoteq screen, as shown in the video below.

PS2 : I found out when i’m playing only the midi notes, the volume parameter is increasing by itself :thinking:

PS3 : The problem seems to be related with the incoming Midi signal, even when i’m not sending any midi data, the midi in led / thru are flashing a little. When i simply give the Zynthian box a little moving , the volume will change, without any midi data sent…

The midi lights may flash continually if you have a keyboard that sends MIDI clock or active sensing signals.

The wierd glitches are more likely due to your power supply or cable. Have a search through the forum for examples. Zynth is much more sensitive to a poor power supply than other applications due to the low latency requirements.

I don’t know about the knobs. Maybe the Zynthian is haunted.

1 Like

Tomorrow I’ll try another power supply as the current one won’t provide 2A.

My controller does not send clock, it’s a Roland A88 keyboard , only notes.

Still might send “active sensing” though. I have one that does.

Hello @thefunkyjoint,

you might search the forum about pianoteq performance and try different versions. The current plugin version is quite performance hungry.

Greetings and God bless, Marius

1 Like

At least M

Thanks will do it, but what the red sign with exclamation actually means ?

Xrun overruns. Simply jack running out of resource. Isn’t always audible but signs of an engine on the edge. Well that’s my view others know more…

Exclamation mark indicates that sone xruns have occurred. An xrun occurs when the sound service (jackd) cannot produce sound output because it has exhausted the incoming audio data stream. This mostly happens when the synth or effects engines are not able to create audio data fast enough. This is most likely due to insufficient processing power to serve the DSP, etc. requested by one or more audio engines. Low voltage may cause RPi to throttle its processor speed which invariably leads to xruns. Some synth / effects engines are processor hungry and may cause xruns, especially if combined with other engines simultaneously playing. Xruns result in “holes” in the audio output (short mutes) which are more audible at higher sound output level. PianoTeq will trigger some xruns on a RPi3, even if tweaked. It can be run at a lower sample rate with very few xruns (maybe none) but this undermines its great quality by low pass filtering. Engines like Fluidsynth use far less processing so may be used without experiencing xruns. There are several engines that are not really useable on RPi3 due to xruns IMO. I am hoping RPi4 will fix these.

1 Like

The Piano sounds of Pianoteq only work with RPi4 to my satisfaction.
The MKII is ok with a RPi3. I don’t have any issues with my RPi4 so far and used it on stage already.

That’s bad news for me as Pianoteq is the main reason i’ve got the Zynthian. Is it possible to upgrade the Zynthian’s RPi3 for a RPi4 ?

1 Like