Pianoteq problem with autoloading of velocity curves

Hi, I just found out that there is a possibility to calibrate the midi keyboard in terms of velocity, note off speed, pedal action. This is a really cool feature. The playing experience is much more natural after calibration than with the default settings.
For calibration you need the pianoteq gui (ssh -X into zynthian, create new pianoteq-layer, gui opens). Then start the keyboard calibration assistant in the menu Window -> keyboard calibration assistant, which will guide you through the calibration. The result can be saved.
If you want to keep it permanently, i.e. over all instrument preset changes, you have to check the corresponding box in Window->parameter freeze and hit “set as default” button. At least according to the instructions.
Now, unexpectedly, the setting is not permanently preserved. At the latest after the restart the default settings are active again and velocity calibration is gone. But you can manually load the previously created calibration curve by calling up pianoteq gui again and clicking on velocity and then selecting the corresponding calibration entry with the previously selected name in the menu.
The second problem is that the settings made under action will be lost after a restart, even if the freeze menu (Window->parameter freeze) is checked. I wanted to switch off the sustain pedal noise permanently.
Has anyone of the pianoteq-users already looked into this problem and knows a solution?
The selected checkboxes (velocity curves, action) in the parameter freeze menu are preserved after restart but obviously that information is ignored.
The calibration file is stored under /root/.local/share/Modartt/Pianoteq/Presets/My Presets/Velocity-fp30-calibrated.mfxp, where Velocity-fp30-calibrated is the name I chose.
But I have no idea where the freeze settings are managed.
I’m using pianoteq 6.7.3 and zyncoder: master (465929c)
zynthian-ui: master (11f49bd)
zynthian-sys: master (0a0ca11)
zynthian-data: master (74ceb35)
zynthian-webconf: master (8efc3ba)

Here is even a list of recommended velocity curves:


Another parameter which is not preserved upon reboot is polyphony which I set to 64 but it always drops back to 32. (not talking about individual presets; I’d like to have some global settings adjusted which should apply for all instruments).

Hi, for the polyphony, the parameter is in the code, you need to make modification on source to keep the 64 note :

1 Like

Thanks, I think this parameter would be a good addition for settings under webconf or in the admin menu.

do you know the parameter in the file we can switch off the sustain pedal noise with?

Hi, my comment was about the polyphony parameter that @lguyome45 pointed out.
But having the pedal noise on/off switch accessible by the zynthian interface or webconf as well would be nice, too. Unfortunately, I’m not at all familiar with the underlying configuration file structure, but I’m sure that there must be a related file somewhere since some settings are preserved (such as the check boxes in parameter freeze window).
BTW, a list of recently changed files gave me this:

root@zynthian:~# find . -type f -mtime -2 -exec ls -l {} \;

-rw-r--r-- 1 root root 8511 Nov 15 10:23 './.local/share/Modartt/Pianoteq/Presets/My Presets/Backups/Velocity-fp30-calibrated.mfxp,1'
-rw-r--r-- 1 root root 2778 Nov 15 13:07 ./.local/share/Modartt/Pianoteq/MidiMappings/Zynthian-4.ptm
-rw-r--r-- 1 root root 9550 Nov 15 13:07 ./.local/share/Modartt/Pianoteq/MidiMappings/Zynthian-0.ptm
-rw-r--r-- 1 root root 9836 Nov 15 13:07 ./.local/share/Modartt/Pianoteq/MidiMappings/Zynthian-3.ptm
-rw-r--r-- 1 root root 9365 Nov 15 13:07 ./.local/share/Modartt/Pianoteq/MidiMappings/Zynthian-1.ptm
-rw-r--r-- 1 root root 8943 Nov 15 13:07 ./.local/share/Modartt/Pianoteq/MidiMappings/Zynthian-2.ptm
-rw-r--r-- 1 root root 870 Nov 14 21:40 ./.local/share/Modartt/Pianoteq/MidiMappings/Zynthian.ptm
-rw-r--r-- 1 root root 4348 Nov 15 14:43 ./.remote_display_env
-rw-r--r-- 1 root root 206122 Nov 15 13:10 './.config/Modartt/Pianoteq67 STAGE.prefs'

So could the settings be stored somewhere here… I’ll check it.

—> checked :slight_smile:
Information is basically there, here is the prefs file: Pianoteq67 STAGE (copy 1).prefs (200.0 KB)
There are entries about key release noise (but not pedal release noise) and parameter freeze.

My guess is that this prefs file is not handled upon pianoteq startup.

No progress from my side, since I don’t have a clue how to resolve it. Should I post a bug on the velocity curve issue on github? Or should I check latest zynthian release first? I have currently installed some release which is half a year old.
BTW, I think it would be nice to have an “about” - entry in the admin menu which shows the zynthian release version and kit version in easy terms (I alwas find the webconf entries about software really confusing or rather undescriptive, zyncoder: master (055b299)
zynthian-ui: master (27ccccd)
zynthian-sys: master (dcf8d8a)
zynthian-data: master (74ceb35)
zynthian-webconf: master (d14b197))

I think, the freeze is not saved persistently.
I compared the config files before exiting the window.

root@zynthian:~/.config/Modartt# diff Pianoteq70\ STAGE.prefs Pianoteq70\ STAGE2.prefs 
<   <VALUE name="windowY" val="365"/>
>   <VALUE name="windowY" val="347"/>
<   <VALUE name="engine_rate" val="22050"/>
>   <VALUE name="engine_rate" val="22050.0"/>
<     <DEVICESETUP deviceType="JACK" audioOutputDeviceName="Auto-connect OFF" audioInputDeviceName="Auto-connect OFF"
<                  audioDeviceRate="44100.0" forceStereo="0"/>
>     <DEVICESETUP audioDeviceRate="44100" audioInputDeviceName="Auto-connect OFF"
>                  audioOutputDeviceName="Auto-connect OFF" deviceType="JACK" forceStereo="0"/>
<   <VALUE name="last_options_tab" val="General"/>
>   <VALUE name="last_options_tab" val="About"/>

You could save local presets with the adjusted velocity map. But you don’t want that, I guess.

@jofemodo, could you ask the pianoteq people if they can provide a parameter like we have with the midi-mapping?

I just discovered that in the manual from version 7 on a global velocity map is possible. Which kind of implies that it was not possible before.
See chapter 10 in https://www.modartt.com/user_manual?product=pianoteq&lang=en.

Note: Calibration, Reset, G.
I can check the behaviour on newest pianoteq 7 on non-zynthian environment, e.g. ubuntu, if that helps.

1 Like

yes, that works.
But the trick is that you have to exit the UI, so that the preset is saved.
I let zynthian close the UI when I tried it a couple of hours ago. That doesn’t save the settings.