Pianoteq sometimes not making any sounds

Sometimes when I set up a layer with Pianoteq I get no sound generated. Other layers using other engines all seem to work, just not the Pianoteq engine. I’ve tried playing around with volumes, channels, removing/re-loading the layer but all without success. Quite often it all works fine, though, so I know it can work on my setup. I’ve not worked out if there is something specific that causes it not to work. Anyone else had this happen, or know what might be falling over behind the scenes?

Have you paid for it?

I’m just running it in demo mode, which I’m aware has certain notes that don’t work, and stops producing sound after around 20min or so. Where I’m occasionally having an issue with it is on a freshly booted up zynth when I create a new layer with the Pianoteq engine. This should be long before the 20min timeout on demo mode kicks in.

Pianoteq in demo mode dies after 20 minutes regardless of whether used or not, it has to be completely quit and restarted to do this.

Out of curiosity, how does pianoteq work on a zynthian? I’d love to know this as I’d like to take one of these on and install it to a custom piano for our church. I’d be donating a license of pianoteq and organteq.


@lewisalexander2020: PianoTeq works fairly well on a Zynthian with Raspberry Pi 4. There are some constraints like internal sample rate is limited to 22050 and polyphony to 32 notes (I think). If you push out hard, e.g. apply effects then it will trigger xruns which manifest as clicks. On the whole or works quite well. It consumes very little resources when idle so can be loaded with other engines if not played concurrently. You can get away with playing it with some engines.

@scro: I have experienced the issue you describe. It is frustrating and I haven’t figured out the cause. I have usually been to busy to fault find so restart the device to get it back. I am fairly sure I have experienced this since buying a license so should not be affected by the demo timeout.

1 Like

Pianoteq performing at that sample rate is a bad thing, it should support 48khz stable at full polyphony, especially v7.3 and organteq 1.62

Is there a particular reason for instability? could it be either the interface board in use or an issue with how audio and latency is? ideally with a pi4B and a tuned linux distro, that should run much better than that without any clicks or crash points.

lew :slight_smile:

Zynthian is doing a lot of stuff beside hosting engines. It certainly is possible to build a bespoke Raspberry Pi running Pianoteq with better performance and we have an open ticket to investigate and improve the efficiency of Zynthian. The modules that may be consuming resources are complex and core to Zynthian’s operation. They need careful investigation to avoid breaking everything. Not everyone has an issue with these aspects of Zynthian so it is not at the top of the priority list. Remember there is a very small team trying to fix issues and implement new features. Be careful of what you ask for. You may divert effort to a less urgent task. (I am sure I was doing something important… )

1 Like

I think I managed to get Linuxsampler to fall over in the same way, so perhaps it’s not a Pianoteq specific problem? I’ll continue to play with it and see if I can spot any pattern to what I’m doing that causes the issue.

here’s a thought, so please don’t shoot me :wink: The issue may in part be to do with the HAT for audio. I’ve had some details over from a dev that some hats though they have the physical qualities, the coding isn’t right so they bottle neck. try a USB external audio interface with midi and test that. you might find it works. Zynthian from my understanding and @riban earlier comment, it sounds to me that the pi, maybe through the OS could choke. Maybe it’s a possibility to refine the audio engine, etc as part of the process.

There is another audio hat which I’m told is more stable, it’s the PiSound interface, however, this would require modifications to the case, etc. If there was a way of a pi running a PCIe audio interface, there’s one or two semi-pro audio interfaces over PCIE that could work, but then that’s more big boys toys lol.

I don’t think this problem is related with using a HAT. From my little experience with Zynthian, a good HAT is the most reliable audio interface you can use, specially those using Burr Brown chips (PCMxxx). This include Hifiberry cards and the new ZynADAC, among others.

@scro, could you send a screenshot from your webconf’s dashboard? When reporting an issue, it’s very important to include the “context”. Without the context, normally we can’t reproduce the issue, so we can’t solve it. Also, if possible, you should specify a list of detailed steps to reproduce the problem. That’s your task! If you do your task, we will do our, that is fixing the issue :wink:



I shall indeed get a webconf dashboard screenshot when I get this to happen again. I’m also going to try and be a bit more systematic in what I’m doing, to see if I can trigger it by something I do. I’m not aware yet of anything specific or repeatable that may offer some clues as to what is going wrong.

For reference, other sound engines on other layers continue working when Pianoteq has hit this issue. Also, sometimes just removing that layer and then creating it again can solve the problem.

1 Like

No no. Do it right now. The webconf dashboard will be almost the same and the more important info wont change at all :wink:

Here goes with a screengrab of my current settings on webconfig dashboard…

If pianoteq is acting odd, it sounds like it could be resource hungry. I have pianoteq 7.3 studio and organteq 1.6.2 on my developer mac and it runs fine, but that’s a serious spec machine. Pianoteq is a rather powerful and advanced instrument, like organteq, both do require particular audio settings and midi settings to be at their most efficient. in order they don’t nose dive. The settings you mentioned don’t seem right for sampling. ideally 44.1khz at 128 / 256 samples is very stable. Could you try an external audio interface set up that way if at all possible? also what are your midi settings for the keyboard you’re connected to. be careful as some controllers send out on more than 1 channel, so you could have midi lag or midi force overload behaviour like I once found on my studiologic SL88. I had to configure pianoteq and organteq to behave differently regarding midi channels.

I’d love to know how pianoteq works as an interface with this instrument, because it has a heavy GUI and browsing parameters could be rather interesting, such as instrument presets.

What is the installed version of pianoteq?

lew :smile:

Zynthian comes with Pianoteq 6 demo. A user can buy a license from Modartt and apply it and can install a later version. I have 7.3.0 installed.

Zynthian provides ability to run the full version or the LV2 plugin. The former presents four controls on the rotary encoders: volume, dynamic, sostenuto and sustain. The plugin presents all / most controls spread over 20 pages. That is 79 controls. Both offer all default presets.

The graphical user interface can be displayed over X11 forwarding or VNC but it is advised to perform with this disabled to reduce resource load.

Are you using the full version of Pianoteq as listed towards the top of the engine’s list or the plugin listed below the “LV2 Instrument” heading? Have you updated your version of Pianoteq or using the default installed version? You could enable Engines VNC and look at the GUI to see if there are any clues to why it is failing. You could also run patchage from the Engines VNC view and check audio output is routed to system playback. If you were also able to extract some log files during an incident it may help.

I just tried loading Pianoteq 6 demo (not plugin) on my V3 and it looks rather unhappy. The GUI has what looks like a no entry sign next to the preset name and the keyboard is disabled. That might relate to the current state of that machine though - I develop on it so it may be self-inflicted damage. My V4 seems to load okay.

1 Like

I had another play with my zynth yesterday. From a fresh boot I set up 3 layers:
1 - Linuxsampler with SalamanderGrand loaded
2 - Pianoteq (“full” demo version, not the LV2) - edit: I’m using version 6 of Pianoteq as included in the standard Zynthian SD image.
3 - Linuxsampler with trombone loaded

This was all working OK and I was able to switch between the 3 layers multiple times and get the correct sounds play with midi input. After approx 10 mins layer 3 stopped producing sound when I went to change the trombone to a cello sound. I could still get layer 2 with pianoteq loaded to produce sound, and change between different piano presets. Layer 1 with Linuxsampler/SalamanderGrand continued to produce sounds, but I was no longer able to change to a different instrument sound. The Zynth interface was behaving normally and made it look like had changed to a different instrument sound, but the audio produced was still the SalamanderGrand patch.

From memory, the problem seems to be triggered when the instrument is changed, and doesn’t appear to exclusively affect Pianoteq. Could it be an issue with reading from the SD card?

@riban you mentioned log files… where might I find/extract log files?

Linuxsampler is the engine that depends more of disk subsystem, so you should try with a good new SD-card, burned with the latest stable release, to be sure. I normally use SanDisk Extreme and never had a problem.

Also, try to disable RTP-MIDI, or any other service, like VNC, when you are not using it.


daft question, as I don’t know the case build or layout yet. could an M2 SSD be installed? or has any level of interface port been blocked by the audio hat? I only ask this as if you look at how SDXC / SDHC cards behave, who they’re made by, etc, some have better read / write speeds than others, if you were to jump to either a sata ssd or PCIE SSD direct from the pi, rather than over USB, if there was suitable room in the case, could that be achieved, if so, that would definitely help in sampling support, the difference in read/write speeds is tremendous. The nearest you’d get to stable sdxc performance would be a class 10U if I remember right, which is a professional level media card. I’ve used these with pro audio field recorders and they are relaible. but the price point does get a bit ridiculous.


GENIUS!!! Well I have pianoteq 7.3 studio full license, so have a spare.

how do I register it on the device, would I have to network connect it to control it from a workstation?


Installing and registering Pianoteq is done via webconf, the Zynthian web-based configuration application.