Pitchbend Error

I updated my Zynthian today, plugged in my keyboard, and started playing. But all the notes were transposed two semitones down!

I thought at first it was a problem with my keyboard, until I tried it on another one and found that the problem persisted.

It has something to do with pitchbend, I think, because I can’t bend the notes down anymore, but I can bend them back up to where they should be.

I’ve tried this with LinuxSampler, ZynAddSubFX, Dexed, and Helm. On Helm, when I increase the value of pitch_bend_range, my notes bend down, almost as if some mischevous spider was holding my pitchbend wheel down.

I tried to get UI logs from the webconf, but, for some odd reason, I can’t access it over WiFi. It’s probably a problem with our home network.

Any ideas, anyone?

Check the midi logs, activate the wifi hotspot if you cannot connect to it

1 Like

Hy, I have the same problem since update. The Midi log shows:

CH#15 NOTE_ON 72, Vel: 81
CH#15 NOTE_OFF 72, Vel: 64
CH#15 NOTE_ON 72, Vel: 96
CH#15 NOTE_OFF 72, Vel: 64

I tried to clear all Layers and made them new, but still the same. My first idee was, that it has to do with the analog inputs I started to test yesterday and pitch bend is still an -8192, so I searched for a way to set it to 0. Then I found this threat.
Any Ideas? Thanks.

best regards, Andy


Seems related to New build V4.1: MIDI ports and irritation


Sorry @guys!

I made an error on my last commit. Please, update and test now …


1 Like

Nice! Now my notes are tuned properly. But it looks like I can’t use pitchbend now. That might be a problem with my keyboard, but I’m not sure. I’ll have to fiddle around more when I have time.

Thanks very much, notes are play correct now and pitch bend is working too.

1 Like

Confirmed! Pitchbend works! Thanks @jofemodo!


Whoops! I forgot to include a :face_with_monocle:!