Problem on webconfig (zynthian_webconf.sh cannot be started)


#1

Hi folks,

I have tried to build a new zynthian with latest image zynthian_gorgona_omega_rbpi3_kitv2-2018-04-03.zip and it works great.

However, webconfig could not be started after updating the software with /zynthian/zynthian-sys/scripts/update_zynthian.sh, and this is the error message when I tried to run the webconfig manually

root@zynthian:/zynthian/zynthian-webconf# ./zynthian_webconf.sh
Traceback (most recent call last):
File “./zynthian_webconf.py”, line 48, in
from lib.midi_config_handler import MidiConfigHandler
File “/zynthian/zynthian-webconf/lib/midi_config_handler.py”, line 38, in
from zyngine.zynthian_midi_filter import MidiFilterScript
File “/zynthian/zynthian-ui/zyngine/init.py”, line 28, in
from zyngine.zynthian_engine_puredata import *
File “/zynthian/zynthian-ui/zyngine/zynthian_engine_puredata.py”, line 30, in
import oyaml as yaml
ImportError: No module named ‘oyaml’

Any clue?

Thanks,
Francis


#2

Hi Francis!

The update has failed, i don’t know why. The oyaml package should be installed after updating but it’s not, so …

1.) You can try to install it by hand with “pip3 install oyaml”

2.) Better, re-burn the SD and update again

Kind Regards!

P.S: When creating a new topic in the forum, don’t forget to choose a category!! :wink:


#3

Thanks for the reply and I try to solve it by reinstalling the package.

Regards,
Francis