Problem with MIDI controller and ZynSeq

Hello everyone.
I am new here .
I don’t know English, I use a translator. Sorry for the mistakes.

I’m having a problem with one of my MIDI controllers when I try to trigger the pads on the ZynSeq:
I manage to map a pad or key on the controller to a ZynSeq pad, but then it doesn’t work.
This controller assigns vel:64 to NoteOff.
When I use it to play there is no problem.
(With other controllers I have no problem with this. But I see that they assign vel:0 to NoteOff.)
Will this be the problem? Any possible solution?

Thank you.

Hi @Patxi! Welcome to the Zynthian community.

ZynPad will respond to MIDI Note-On commands with velocity > 0 only. Is the controller sending a MIDI NOTE-ON with velocity 64 for note-off?


However I play any synth with no problem.

This should work. Ensure you have not set the “Master Channel” (in WebCong INTERFACE->Midi Options) to the same as the controller.

For CH#16 NOTE_ON 40, Vel: 36 you should set ZynPad:

  • Trigger channel: 16
  • Trigger note: E2

I have it configured like this, and with the Snco smk 25 controller it doesn’t work.

With the Conspiracy controller instead it works.

It catches my attention that the failing controller sends noteoff vel: 64. In my ignorance I think that maybe that is the problem.
What do you think?

Those MIDI commands are working for me, i.e. if I send:

  • CH#16 NOTE_ON 40, Vel: 34
  • CH#16 NOTE_OFF 40, Vel: 64

then the configured ZynPad will start or stop.

Have you enable the MIDI device input in Webconf INTERFACE->MIDI Options, MIDI Ports: MIDI INPUT Ports?

Yeah, and I’m playing Sfizz with it.
I have the mysterious problem with ZynPad.

This is strange! Please show the MIDI log for “ZynMidiRouter Main” when the issue occurs.

Ah! I think I have it. It may not be the keyboard but the MIDI channel / active chain. There seems to be an issue that the MIDI signal sent to the sequencer is influenced by the active chain if Omni/Stage Mode is enabled so the active chain’s MIDI channel is used, not the external controller’s MIDI channel. This is a bug. Will you please validate that this is what is happening for you?

I’ve got it!
The controller appears three times.
I have only enabled ‘‘SINCO SMK25 Master’’ and after restarting now it works.

Thank you very much for the help. It has been a pleasure.