Problems configuring the new official display "PiScreen2" [SOLVED]

Dear José,

thank you very much… yesterday the zynthian arrived…
Now it is ready!
BUT! it dont work correctly with the display…
I don’t know the correct settings for it.
With hdmi waveshare display it boots and the controllers and all is working.
Then i switched to the internal display over webinterface…
The piscreen1 works sometimes after switching…
But not after a reboot.
After rebooting with piscreen settings the system hung…
I spent ours and ours now, but not able to find a solution.

Do you have any idea?

Best regards

Dear José,

ours of investigation…

  1. booting with display disconnected…
  2. configure PiScreen2
  3. disconnect power.
  4. connect display plug.
  5. switch power plug on.
  6. boot with PiScreen2 configuration.
  7. go to the webconfiguration select PiScreen1.
  8. system reboots display is working…!!!

after disconnecting power and rebooting again system hangs while first zynthian splash screen…

The whole procedure is absolutely repeatable!

i am going crazy…

Best regards

Hi @MartyMcFly!

Please, try to “update” the image. The last week I’ve improved the configuration process for the PiScreen and it should work if you update your image.

You can do it from the Zynthian GUI (use an HDMI display):

Zynthian Updating - ZynthianWiki

Or you can do it from command line. In such a case, you have to connect your Zynthian Box to your local network (router) and login using a remote terminal (ssh) from your computer:

Command Line User Guide - ZynthianWiki

When you are in, simply execute this command:

# /zynthian/zynthian-sys/scripts/

Anyway, i will upload an update image ASAP. Probably today or tomorrow.

Kind regards,

Dear José,

i had done the update over the gui before…
now i called the update over ssh…
no change in the strange behavior.
Same effect as i described.
Also tried with a different RPI3 - change had no effect…
also tried with another sd card - no effect…

drives me crazy!

Any other idea?

Perhaps the display is damaged?

But why should it work with the workaround i found out?

Best regards

Are you using a fresh Gorgona Edge image? Is your Zynthian connected to your router?
Please, send me some photo of how did you connect your display to the ribbon cable …


2 more tips:

  • The correct driver is “PiScreen2” … PiScreen1 is an older one and wont work with your display!
  • You don’t need to reboot or unplug/plug the cable after configuring the display, as the configuration system alreasy reboot the system after saving the config.


Ahh! I’ve moved this issue as a public post for better sahring the knowledge … :wink:

Dear José,

yes i am using the brandnew gorgona image…
The Zynthian is connected to the internet via a switch and a router.
with piscreen2 i got no output…
I only have to unplug and disconnect because the booting hangs and dont go to the end.
It hangs on the zynthian splash screen in this case…

OK PiScreen2 - strange…

Perhaps i had connected something wrong.

Best regards

offtopic: I never got an email from the forum when you reply to me…

OK! I think i have it :wink:
Try these commands:

rm /zynthian/zynthian-sys/boot/overlays/waveshare*dtbo

Then go to the webconf tool => display config => save

After that, you should increase the font size to 14 in the style tab :wink:


Regarding the mounting … are the screen separator too long?
I think i make an error and the separators i sent are 0.5 mm too long. We have 2 options to solve it:

  • You cut/lower the separator using a cutter/sand.
  • I can send you the right separators :wink:


The display is working fine.
Also after switching off the power!!!

Now i can take the Zynthian from the workbench to the studio and hear it!!!


Thank you very much!

I think the screen separators are not too long in my opinion.

Best regards

Congratulations!!! jejeje! You are the first person who has succesfully mounted an official Zynthian Kit V2, excluding me, of course :wink:

If it’s OK for you, it’s OK for me :wink:


Dear José,

wonderful little box… i played a little bit around here in my studio…
makes a lot of fun…
THANK you very much for your support and your whole project.

Now you can place me on your google map :slight_smile:

Best regards

1 Like

Hi José, Marty,

i got my Zynthian today as well, and i got it assembled without larger difficulties The instructions were very clear and everything fitted nicely.
After ‘etchin’ the SD-Card image it booted, i can access it via ssh and i followed the update instructions mentioned above whicht helped to get the screen working.

But unfortunately the Zynthian display shows an error message after the inital Zynthian splash screen.

Please see attached photos for my wiring and the mentioned error screen, additionally i included a screenshot of gpio readall

What can i do?


and here is screenshot of zyncoder_test.

and this repeating error message shows up in the terminal when running Zynthian UI in the console:

systemctl stop zynthian


Have you set it up in the webconf already?

In the webconf i set up display as piscreen2, are there other settings to change as well?

The wiring and the audio card

Wiring is set to PROTOTYPE-4,
Audio is HifiBerry DAC+