Problems enabling the 3.5mm jack (on-board sound card)


#1

I’ve been trying to re-enable the build-in sound device of the RPi 3b+. However I had no luck, the card does not show up in the “aplay -l” and the sound device does not show up in “cat /proc/asound/cards/”. How can I enable it?

The quality has improved according to http://wiki.zynthian.org/index.php/Configuring_Audio_Devices. But unfortunately adding “audio_pwm_mode=2” to /boot/config.txt does not work.

p.s.
The sound device works perfectly fine with the current Raspbian image (2018-06-27-raspbian-stretch.img) and has low-latency for e.g. in ZynAddSubFX. So I would really like to give Zynthian a try.

Edit #1:
To be clear: I dit not manage to enable the on-board soundcard. I was under the impression that is was explicitly disabled so my question is:

How can I re-enable the on-board sound device in the Zynthian image?


#2

How did you re-enable the RBPi sound card? Could you give some details?

Thanks,


#3

I could not enable the sound card in Zynthian. I cannot find any trace of how the card has been disabled (no drivers blacklisted, no special ALSA configuration in /usr/share/alsa.conf).

The main reason I think is is disabled explicitly is because the sound device works perfectly fine when I use the Raspbian Stretch image (and the sound quality is good).


#4

I finally managed to get it to work.

Just add “dtparam=audio=on” to /boot/config.txt. It also helps to choose the default sound device for ALSA because sometimes the wrong default card is chosen. In my case the Roland UM-ONE was chosen as a default, which obviously cannot play PCM data :slight_smile:

#Edit the ALSA config:
sudo nano /usr/share/alsa/alsa.conf
defaults.ctl.card “ALSA”
defaults.pcm.card “ALSA”


#5

Thanks! I will test it and if it’s working OK, we will add this config to the webconf tool :wink:


#6

Have we just lost the sync output or do we use an hifiberry card for that? :stuck_out_tongue_winking_eye:


#7

The sync-output that we never had …:rofl::rofl:


#8

Hi @mrClass,

I’ve configured the Pi’s on-board sound device and i’m testing it with Zynthian.
It’s not the first time i do that. I did at the very begining of the project, but the sound quality and latency were so bad, that i completely forget this device.

After reading your comments, i’ve tried again … but everything is the same . Very poor sound quality and a huge latency. I tried with different jackd options, but nothing improves …

Could you send us your jackd options and a small “analog” recording for comparing?

Thanks a lot!