Problems saving ZynAddSubFx patches

Yes… I have searched the forum for answers on this. I’m not just a lazy noob. :slight_smile:

I have had no trouble at all saving new snapshots for any synth from the Zynthian UI but I am having trouble saving new presets for ZynAddSubFx. I use X11 forwarding over SSH on Ubuntu to edit ZynAddSubFx voices. I have tried either “Save All Parameters” which saves xmz files and “Save Instrument” which saves xiz files. I am saving these files to the following path.


When saving them, the xmz or xiz file is saved immediately and visible via SSH. The problem is that the whole Zynthian becomes very unstable after that and needs to be rebooted after saving a preset. The last time I tried it, the Zynthian UI became unresponsive and I couldn’t even reboot the Zynthian from the webconfig. I had to pull the power. After rebooting, the newly saved xmz or xiz preset is located where it should be, shows up properly in the UI, and works just fine when loaded causing no instability.

My Zynthian is updated as of yesterday and has been running quite stable in the last week of messing with it. I have a 64G Sandisk Class 10 card in it.

I have had no problem making realtime adjustments to the voice from the X11 UI. Everything responds as it should. It is only when trying to save ZynAddSubFx presets that it goes all wonky.

What am I doing wrong!?

Thanks for any help.


I tried it again just now. At the moment I press Save Instrument on the ZynAddSubFx UI. A number of XRUNs show up in the debug mode log. The audio out stops and the UI becomes unresponsive. The webconfig cannot reboot. A full power cycle is required to bring the Zynthian back.

I was able to edit the Aeolus synth to reset it to Equally Tempered tuning from that horrid sounding Mean tuning. Saving those changes worked perfectly so it’s not a file I/O problem.

For the time being you could maybe use ZynAddSubFx on the desktop for creating patches, and then use the webui to upload them to the zynth?

True but an unfortunate inconvenience considering this should all be possible on the Zynthian with X11 forwarding.

I wonder what the ZynAddSubFx process could be doing that kills the Zynthian.

If anybody else can duplicate this it would be helpful.

Hmm… this might be a clue. Could be something similar.

I ran the same scenarios while watching the Zynthian processes with “top”. After saving the “instrument” file the ZynAddSubFx process dropped from around 10% cpu to about 1%. In a couple cases I was able to get the Zynthian to reboot by issuing the “reboot” command via SSH.