Problems updating the Software from the Admin menu


#1

Hi @all!

If you have problems updating the sofware from the admin menu (i.e. you get an ERROR message), use this thread to post a photo or description of the message.

Regards


#2

Hi Fernando,

yes - I have update problem. When updating from shell I get this:

...
Updating zynthian-ui ...
From https://github.com/zynthian/zynthian-ui
 * branch            mod        -> FETCH_HEAD
Updating a6438bc..a3666f4
error: Your local changes to the following files would be overwritten by merge:
        zynthian_gui_config.py
Please, commit your changes or stash them before you can merge.
Aborting

After

cd /zynthian/zynthian-ui
git checkout .

it works.

Regards, Holger


#3

… additional:

After update my encoder configuration is lost. Perhaps this can be putted in a file which can’t be erased/overwritten by updates?

Regards, Holger


#4

I think that now it’s solved. Update system should make a copy of your configuration and restore it after updating.

Plase, reconfigure your encoder configuration and try again.

Anyway, i’m working in a better configuration system :wink:

Regards!


#5

Many thanks! It seems to work - but perhaps because I manually updated before… will try this soon for my other Zynthian (it’s good to have more than one :wink:!)

Regards, Holger


#6

Hi @jofemodo,

super-fantastic! Update worked on my other Zynthian! Many thanks!!!

Holger