Problems with the SD image

Hi,
I’ve downloaded the software (2019-09-24-zynthianos-buster-lite) and extracted it to a new SD card.

When I boot up my pi3b I get a Zynthian password prompt and the screen keeps cycling to black every few seconds.

What am I doing wrong?

This is normally the sign that jack isn’t starting.
Now you don’t say if you are building on Mofo tin or freeform build, so if the former, you probably have a problem somewhere, and if the later you need to log onto the webconf (a local browser connected one wired Ethernet originally.) and set up your zynth to recognise firstly it’s a custom build and secondly which audio card config, because althou’ the gui reboots if no jackd the webconf server will still run, and allow you to config the zynth.

If you are using an official kit, then once again the webconf is a good place to try to go, and failing that an ssh terminal from Putty will allow us to work it out if you post the results here. . . .

All I did was download the Buster lite version and use Etcher to write it to a new SD.

I put it in the Pi and powered it up.

I got the four raspberries and then a prompt for a password - the screen kept switching to black every few seconds.

Luckily the webconf should be running and from there you can convince the zynth what it really has connected… A bit like dark star… https://m.youtube.com/watch?v=h73PsFKtIck

1 Like

I clicked on that link thinking it was a Zynthian tutorial :rofl: :rofl:

Ok, so the Zynthian needs to connect to the internet to continue?

…so I just ssl to it and sodo nano webconf?

Ok, I’ve read a bit more about it - so I should be able to go to webconf from a browser on a different computer.

So I should ignore what’s happening on the RPi screen (via HDMI)?

I figured it out…pi on Ethernet - webconf shows up fine.

I’ve configured WiFi.

Now I guess I’d better buy some kit!

Hi @Dazzathedrummer!

The Zynthian SD image is pre-configured for working with a very specific combination of hardware parts. If you try to run the image in a raw RBPi connected to a HDMI display, you will get the result you describe. It’s the expected behaviour :wink:

As @wyleu has pointed, you should re-configure the hardware using the webconf tool, as described in the wiki:

http://wiki.zynthian.org/index.php/Accessing_Zynthian_from_your_computer

Kind Regards,

Hi there, i have the same problem (rpi4). I have configed the webgui so that im using custom kit, generic audio usb, generic hdmi display. Plugged in my usb audio. But still same problem. Im using the latest green build. Do i have to do iniial startup in a specific order? Do i have to have the midikeyboard plugged in aswell?

Best regards

Probably your usb audio device is not being recognized. Could you access by ssh and check if it’s working?

My usb card is visable with aplay -l , os has workd before with the exact same hardware :frowning:

The zynthian log would be very helpful for diagnose your problem :wink:

Access by ssh, execute:

# systemctl stop zynthian
# zynthian.sh

and send the output from it.

regards,

1 Like

I tried to plug in my midikeyboard and it booted fine again. Sorry for the trouble. But good to know in the future :slight_smile: Seems like jack wont start if no audio or midiinput is connected when doing custom kit. Once all connected it worked fine.

3 Likes