Radiohead on Zynthian

I did a take on Everything In Its Right Place by Radiohead using the SalamanderGrandPianoV3 engine with zynreverb room acoustics effect applied.

I am using a Raspberry Pi 4b with a HiFiBerry DAC2 Pro and the following Jackd command line parameters:

-P 70 -t 2000 -s -d alsa -d hw:sndrpihifiberry -S -r 44100 -p 512 -n 2 -X raw

I am not noticing any latency with these settings, but I am still getting the occasional xrun (e.g., at around 30 seconds in the attached recording). I’m wondering if it’s because I’m saving my recordings directly to the operating system’s SD micro card? Is there a way to save the recordings to an external USB stick instead? Or should I try setting the Frames per period to a higher value ( suggests the default is 1024)?

Thanks in advance,


Nice theme … and nice playing!! Congrats!!
If you agree, i would add it to the audio demos on the wiki :wink:

It’s difficult to say. You could try and see if it improves. Simply plug a memory stick and it will be used for all audio & midi recording.

If you do so, probably you will reduce the XRuns, but the latency will be double. Too much for most players.



Thanks @jofemodo, much appreciated. I will try recording direct to a memory stick and see if that improves the XRuns. You’re welcome to add this recording to the wiki if you like.

1 Like


Zynthian Sound Demos - ZynthianWiki

1 Like

I think you are probably running at the highest latency before it becomes significantly intrusive.

Ensure you disable headphones and VNC.


Thanks @riban! I had already disabled RBPI headphones but I had been using VNC, as this is a standalone Raspberry Pi box, so that sounds like it’s the culprit. I will try hooking this up to a proper monitor, keyboard, and mouse and disabling VNC to see if that fixes the issue.

Nothing much to add, just wanted to say lovely work @tkc!

Radiohead is a favourite, and this song is a favourite among favourites, and your recording is wonderful.

Thank you for sharing!


Also check your temperature. This is shown in webconf bit not dynamically so refresh page to get current temperature. I have a unit that starts to xrun after a while and I think is temperature related. Do you have any cooling on the Raspberry Pi?

1 Like

Also try it from fresh reboot. There is a bug where restarting the UI causes xruns. We haven’t diagnosed that yet so it is plausible that other operations might trigger a similar issue.

1 Like