Raffo is broken

Raffo crashes.

Yes. I just realized that Raffo is broken. Finally lilv LV2 library has totally deprecated the Event extension, and we have to migrate Raffo to Atom. I’ve been trying a little bit, but only got segfaults …

Perhaps some LV2 master could help me with it … :wink:



I have a love/hate relationship with Raffo. Some days I think it is awesome and other days I think it is shit.


Jeje! You can continue your relationship … Raffo is working again!
Simply update and run the install script like this:



1 Like

Awesome. Thanks!

Didn’t work for me but i’m probably doing something wrong. I just run the script in the console and when i open a Raffo layer it crashes when selecting a patch.

Are you running Buster or Stretch image? Is your image updated to the last?
Please, try to run the script again and send the output from the script …


Image is Buster 2020-02-29. I tried again after another update and it seems to go on. Now it won’t crash but Raffo won’t load at all. This is the console screenshot.

Did you update before running the script? :wink:

Yes. I’ve tried again, updating and running the script, but nothing changed.

I’ve just tried to load Raffo in the MOD-UI and it works! Still not working as a normal synth layer.

Try the latest image:


It should work out-the-box :wink:


Done, and works very well now but there is another problem: if i load a synth, no matter what, everything is fine. If i add an effect, sound disappear completely🙄

Ups!! Devil is on details … i think it’s fixed now. Update, test and confirm, please …


Yeah! Seems ok now. Thanks a lot!

@jofemodo Is this the problem where the autorouter doesn’t connect the engine to the effect?

Yes, it’s regarding the connection if effects

1 Like