Received my new Zynthian, but display seems dead?

Hey all, I got my V3 kit today.
I assembled everything, flashed an sd card, and started up my Zynthian.
However, the display stays black and the logo never shows up when I boot it.

I ssh’d into the machine and looked at the xorg logs and it seems like the display is correctly detected (I don’t see any errors), it prints out the resolution correctly, etc.
I tried cat /dev/input/event0 and the touch event logs show up as I touch around the screen which makes me believe that at least the touch component is working.

However, the screen is completely black.
I wonder if it’s either a ribbon cable fault, or the backlight from the display is damaged? I think I have wired everything correctly, I already tried removing all the cabling and re-connecting everything making sure I do everything right, but it’s still dead unfortunately.

Any help?

An update:

I set up X forwarding via SSH and was able to launch the UI remotely, everything works. Touchscreen events show up, the knobs all work as intended, I can click on them, etc etc.
The only problem is that the screen seems dead.

Either it’s a damaged screen (or backlight?), or the ribbon cable broke exactly on the pins that regulate the screen (but not the touch or knobs) which seems like… a weird coincidence.

Or maybe it’s a software error? Not sure.

Can you measure voltages . i.e. do you have a multimeter?

IF so check for 5v on the appropriate pins on the display.

Hi @Morg!

We are testing every display before shipping, so it’s strange … anyway, it seems to be broken, so please, send me bak the display and the ribbon cable. I will check where the problem is and send you a replacemet ASAP.

Fernando Moyano - Made BCN
Noguera Pallaresa 59-61
08014 - Barcelona

and excuse the inconveniences …

Kind Regards,

Hey wyleu and jofemodo, thanks for the responses. No worries, stuff happens :slight_smile:
I do not have a multimeter to test if pins are broken in the ribbon cable, but I can try to procure one in the upcoming days and see if I can work around it.
I have never shipped anything internationally from Japan so I’ll see how that works and get back to you. I’ll be busy and going on vacation for a couple of weeks starting Monday so it might take some time to get all of this sorted out, but I’m not particularly in a hurry.
I’ll let you know how it goes, thanks!

Quick update on this.
It’s definitely the backlight not coming on, I have tried shining a torchlight on the display and I can faintly see the menu but it’s really hard to read.
I tried testing all the ribbon cable pins using a multimeter and they all work as intended so that is not broken.

Now I’m actually wondering if it might be a software bug or if it’s possible to test/play with the backlight from udev rules.
Anyway if no one has any ideas for a solution that doesn’t involve shipping the display back (kind of a pain from Japan, to be completely honest) I’ll get around to doing that in a couple of weeks after I come back from my vacation :slight_smile:

SSH into it and try:
echo 0 | sudo tee /sys/class/backlight/*/bl_power