Repeating changing Colors in intervals on IPS Screen after initial boot


I’m having trouble setting up my custom Zynthian build. The first issue I encountered was that, as mentioned in another forum post, the current stable release of Zynthian only boots into a command line where I can login.

Following that, my second and current issue is, after I flashed the stable release 2306, I could see the normal Raspberry Pi initialization during the first boot (So, the display output seems to be working fine right from the initial boot), but following that, it displays the colors white-red-green-blue and black in intervals repeatedly. This keeps happening continuously.

Any ideas? Is this related to display drivers? I am able to log in via SSH. I’ve already tried reformatting the SD card multiple times with different images. Also tried rebooting multiple times and running apt-get update and upgrade.
On Release 2308 at least I could see and use the console after initialization.

Thank you really much in advance! :slight_smile:

Here is my Hardware:
-Raspberri Pi4
-InnoMaker HiFi DAC HAT PCM5122
-Freenove 5" 800x480 IPS Touchscreen
-SanDisk Extreme 64GB Micro-SD-Card
-65W Lenovo Universal USB-C PSU (2A@5V) (tried others)

Imager Softwares used:
-RPI Imager

-tried with and withouth Ethernet connected at first boot

It sounds like you need to configure your hardware using the web config

To clarify. By default zynthian os is expecting different hardware to what you have.

1 Like

I have occasionally seen a very similar problem on my V5 unit. Does anybody have some knowledge of what these flashing colors mean? Is it a deliberate error indication, and if so is it the screen module or the Raspberry Pi issuing it?

I can´t login into the web interface. Error message is “Authentication Failure” when I try a wrong password it says “incorrect password”. So the password should be right.

SSH with user “pi” is working as mentioned tho.

In another forum I have read, that cycling colors mean the display gets no input. I have not checked it thou. I need to try giving the display current and see if the same behaviour occurs.

1 Like

Check the date and time is correctly set on the pi.

Also try different browsers.

Yeah already tried that. I´ve read about the problem in another post. Current time is correct via ntp, setting time manualy does not help. Tried different chromium browsers and firefox + developer edition.

I have to correct something. I just reflashed the SD-Card with the 2306 image and using rufus. SSH was working, because I tried setting the password via the rpi imager. The times before that, I could not even get into ssh because I always got access denied and the authentication failure on the webinterface. This is also the problem I am facing again right now. The password is correct, I checked, but there seems to be something weird with initializing the user?

btw. I have checked the md5 hash of my downloaded images and they are both correct. Maybe I should try setting up the image with just the raspberry pi and no extra hardware attached. I can´t imagine, why I am getting so weird result although having the same coreboard as so many others.

I’m pretty sure changing the ssh password won’t change the webconfig password.

Also ZynthianOS is a customised os. If rufus is changing things it might be breaking them.

Zythian reccomends etcher. Zynthian Software - ZynthianWiki

Are you using https or http in the zynthians url?

Jofemodo was able to find and correct the problem. The next zynthian setup was building efortless and I could configure all devices with minimal effort. I will post the solution to fixing the cycling colors problem later. It is a driver configuration.