Sanity check on V2 (all in one?) encoders with current stable build

Using the latest stable build, i can not seem to get the encoders to function. i have an old backup which seem to work fine. Is there a hoop that i missed?

working config (from backup) looks like this:

Do you see anything wirh 12cdetect - y 1? That will tell you if the 12c bus is detecting things properly.

looks like what i would expect, still, no function. At least, i think that looks correct?

From memory the 20 is correct. It does at least confirm it up to the mcp23017… Heavy multimeter check? A lifted earth can make it all seem unresponsive. Does anything work? And check and confirm the interrupt pins.

see, this is the thing: i put in an old backup card and it works just fine. it sees all the encoders and buttons.

BTW wyleu, thank you for the tips. i really appreciate your time.

I did detect a change in one i/o pin but that was related to GPIO not i2c . . .

I can confirm 12c is still functioning on stable testing and zynmixer branches. Can’t remember the i2cdetect commands to output data but I’m pretty sure there is one.
Getting confirmation from hardware to software will help tie down the location, but an overall failure sounds like config issues.
You can stop the zynthian process…
systemctl stop zynthian

and start it on the command line
cd /zynthian/zynthian-ui/

You should see any error messages that might tell you more.

Don’t worry, you will pay . . . . :face_with_monocle:

My working settings.

My wiring settings are identical, still no luck. Stop/ start yielded:

Just a thought is 12c enabled 8n raspi-config?

yes. i am buffaloed.

We are missing something here…ehave you tried a new virgin sd card and stable? I have had similar weirdness from bad shutdowns and incomplete disc writes?

just re-burned, same deal. this is a cap of the version i am trying to make work: image

Oh well that another possibility removed. Well let’s focus on the i2c bus and se if things are actually travelling over it. You can start with the emulator which should test overall functionality. Another thing to try is enable the cursor and using a mouse check if things function normally. Simple stuff I know but we need to know what is and isn’t behaving properly in this pipeline.
I2cget is a command that will display data on the bus, but I’ll have to do a little reading to see how to use it.

wyleu, ok, the encoders started working. things i noticed: the GPIO was off by default (i do not know why) and the encoders started working following a switch back from “Dummy mouse mode.” bizzaro world!


Well that’s a relief! I was really getting confused with this one!

You do, of course, realise you have but one thing to do now? :face_with_monocle:

well, one less thing since they put the screen calibrator! after that, galactic domination?

Don’t think I haven’t tried!