Select knob are not working

Hi zynthianers, ive assembled my 4.6 zynthian, amazing machine, but unlikely the select knob on the left doesn’t work, any suggestion?

Now what do you mean by doesn’t work?
Does it show any sign of life at all ?
It is firstly an electrical device and if there isn’t electricity getting to the appropriate places then nothing will happen.
The encoder mechanism is really just three cleverly placed swtiches which connect to the power supply negative ground pin ( a bit like a car really) . The Raspberry Pi or it’s GPIO linked mate a zyn board, rather cleverly holds the pin high at it’s end and sense the encoder events when those pins are pulled down to ground by the encoder switch elements.
The upshot of this is that a missing ground connection to the encoder can produce a completely dead encoder.
There is much you can rule out as the other encoders work, so that makes issues like 12C bus and other niceties irrelevant.

So perhaps, if you have a multi meter check for electrical continuity at the encoder itself, to ensure the OV ground is connected properly.
This will, at least convince you that the hardware side is ok.

There are software reasons why this may not work but it’s always best to start with hardware. At the end of the day software is really only an opinion on the real world.

1 Like

I mean that the machine work and start, but the back button and his rotary does not allow e to do anythink.
so I can’t go backward.
And no, I haven’t got any multimeter.
software seems to be all right, while i can’t check if it work because back rotary, and layer rotary seems to not working at all.

So you have two encoders that don’t do anything?
The back encoder is certinly an important part of the GUI intrface.

You can check functionality of the ynthian by plugging in a keyboard and using the CUIA controls This will, at least confirm the zynthian itself does stuff and will allow you to use the machine. another way is plug a mouse in and then turn on the cursor in the webconf GUI options.
This will also allow control. The trick is to know the top label on the GUI is the back button for mouse clicks.
With the encoders you need to sensure what does and doesn’t work.
Try swapping the encoders between the different sockets on the zyn board. That should identify which side of the connectors the problem lies.
A careful visual inspection when you know you have the faulty component in hand can often solve hardware issues as you are sure the component you have in hand is not functioning properly.

That way you should be able to identify which encoders and sockets work and which don’t.

clear enough, apart from gui and other thinks that are not my normal enviroment.
but those item are on warranty?
because i’ ve never used, they arrived here faulty i rekon,
they could be or the controller module or the cable or the monitor.

any adress where to send my item in order to check their functionallity?

I’d take it up with @jofemodo, who, I suspect, will be along shortly. . .

A little investigation will pay great dividends because knowing which component has failed is important to identify so that everyone is sure where the problem genuinely lies.
A photo of the inside of the case showing the encoders and their wiring will go a long way to ensure we are all looking at the same thing.

1 Like


yes before select bottom wasn’t working, because visually I was connecting the cable in a way that they could be the same.

Instead one cable is inverted as colour. Make me going crazy.

I’ve inverted the switch. They all seems to working well.
I’ve checked the connection cable, and one doesn’t corrisponde to all other 3 cables.
So, could be the cable in itself, or the monitor port that could be damaged by this cable connection,

I still wonder if is not more simple that I’ll send you the zynthian assembled, in order to check this item.

In any case I followed your assembly tutorial step by step.

And I strongly recommend you to update the picture, because they do not corrisponde with the part I’ve received, making this fantastic DIY project really complicated.

In any case as it is not much usable.

Cable Color seems to be inverted while different like Color from your tutorial
The head has got pin inverted for sure.

unlikely inverting the knob the result is the same, so i think is the monitor port.
due to an inverted cable, really sad…

Have you tried swapping specific encoders to different encoder sockets?
If the back encoder can work as the select encoder that proves both the back encoder and the select socket for example.
Methodically building up a chart of what works with what, whilst tedious initially, will confirm the location of the fault. It will also flush out two problems which is unlikely but possible.

Do I understand you?

Only the bottom left encoder/switch was now working? (You originally said the “select” encoder wasn’t working which is the bottom right.)

You have fixed it by reversing polarity of the cable.

So the fault is an incorrectly wired cable which @jofemodo can assist with.

Im sorry but from the previous picture is clear that one cable has got inverted cable, maybe causing major damage to monitor port.

it’s very unlikely it will damage the port. The use of OV ground as the common switch level means this is all pretty passive.
Have you checked all the cables for correct orientation?
If you have 3 that are right and one that is worng try plugging in one of the correct ones into the socket the faulty cable used.
That will reassure you that the port isn’t damaged.

Hi @lucioluongo !

Controller cables can’t be reversed in V4 kits. You can connect them in both ways and they will work anyway. The color order doesn’t matter. Trust me :wink:

But cables can be broken or faulty. Also encoders. And yes, Zynscreen connectors and circuitry can be faulty too. So, let’s try to determine where the problem is so i can send you the needed replacement parts, OK?

First, you could try to swap the encoders, back and select. If the select emcoder works in the back positionm i would send you a controller replacement. If not, try swapping cables. If cables and encoders are OK, then the problem should be in the Zynscreen:

  • Option 1: The pins inside the JST connector are bended. You can look inside with a magnification glass, If they are bended, you can fix it using a fine tool and some care. I’ve fixed a few ones like this and it0s not difficult at all.

  • Option 2: If the JST connector is OK, then something is wrong in the Zyntscreen. It could be a bad chip, solder bridge, etc. I would send you a Zynscreen replacement, but please, in such case, send me back the faulty unit (cheap standard postal service is OK for this).

Your Zynthian will work 100%, anyway :wink:

Best Regards,

1 Like

Hi, Jose, thank for your reply, sound great. I’m going to have a double check whit a magnifying lens. I think should be just the cable, I’ve already inverted them, and I think they work.
Will follow picture in the next few days.

Hi Jose,
Finally I’ve got an extended investigation.

Unlikely for those test probably I’ve damaged all the cables, so just because I had not tested the real functionality of your machine, I’ll include in the return package, in order to be tested on another zinthian. Is up to you decide if they are all faulty or not.
For sure one of them is really demaged.
Here photo cable 1:

Here photo cable 2:

Here photo cable 3:

Here cable 4 damaged, you will find inside the monitor pack:

All other cable (the one to be tested) connector are outside the monitor pack inside the envelope:
Processing: 84C1E62B-2106-4738-BD07-99B28AC6A9D1.jpeg…

Unlikely the monitor port as you said are bended (first two connection of the back rotary button):

I’ll try to avoid regular post. In the next few days I’ll send you with ups this package, where and to attention of who, I have to send this parcel?

Thanks for your time