Sequencer trigger note save not reliable

I am preparing sequences for today’s street party and I am strangling to set trigger notes. When you save a trigger note on one sequence it often delete trigger note on another sequence previously set even thought trigger note is not the same.

I originally thought that maybe this is intentional so that one column of sequences can have only one trigger note so I arrange them horizontally and I have the same problem. So far I have managed only to save trigger note on two sequences and whenever I save on a third one it removes one previously set.

What version of software?

Latest oram

I can manage to save only trigger note for two sequences if I try to set to third sequence it set it but at the same time delete all other trigger notes from other sequences.

It is working fine here. I was able to assign 8 MIDI notes from MIDI channel 10 to 8 zynpad sequences. I used the MIDI learn feature, i.e.

  • Set Trigger Device & Channel from menu
  • Select / highlight the pad in zynpad
  • Select menu options “Trigger Note”
  • Play a pad or key on my external MIDI controller

I also set manually from the menu / encoders. It is working fine on my fully updated Oram.

1 Like

@riban I tested it again. I can not run you workflow because I can not set trigger note by playing a note on the trigger device and appropriate channel, I can only set it using encoder.

You can see in the video that I have set Trigger device for Novation’s impulse, set midi channel to 3 so that trigger note does not play instruments on channel 1 and 2, set midi channel on impulse to 3 as well.

I am on fully updated Oram. This video is from rpi 5 but it is the same behaviour on rpi 4.

Have you tried to set trigger note by encoder and check that it does not delete trigger note for some other sequences already set ? Remember that we have similar bag where if you set trigger note by encoder it saved it as halfnote up while if you set it by trigger device it saved it properly.

Ok, I did further tests. If I set trigger device to “All” then I can set trigger note by playing the key and I can set to all 8 sequences and no trigger note previously set on another sequence is deleted.

So probably this means that if you can set trigger note by playing a key from device that is supposed to controll sequencer everything is fine.

So the question is why this specific trigger midi device recognised by jack and available in trigger device options is not recognised when setting trigger note even though it does when you set trigger device to “All”.

Oh, bugger there were two Impulse devices in options, so only one worked. It is hard to see that there were two because screen only show one and you select first one that appear not knowing that could be another too. I will check now jackd why is there two devices with the same name.

Many modern MIDI USB devices expose several MIDI ports. Frequently one for playing and a second one for “DAW control”. This is very convenient for integrating devices with “kind of DAW” software. For instance, we use this feature for implementing some controller drivers, etc.


1 Like

Thanks @jofemodo , Yes I thought that something similar must be issue - if only midi devices would not use the same name for both of them so that we know inside zynthian what is what.

They don’t, but frequently the only difference is in the last character, what cause trouble when names are too long. If only manufacturers would use shorter port names!!! :sweat_smile:


1 Like