Setbfree crashes (and some bugs)


Although I am loving the possibilities so far, I am kinda stuck. I can’t seem to get setBfree working.
If I open the softsynth version of setBfree, choose Upper, than Sinus, it crashes.
If I open the LV2 version, it does not give any preset selection at all, so that does nothing.
Any clues?

Furthermore, before I start bugging the developers at github, am I the only one with these?:

  1. !general: when I play a sound, and am in the instrument view, clicking a bit through the parameterlist, then the sound changes. Some control changes seem to be SENDED to the synth when I just click through them. Aghr! It is consistent, in every synth I tried. Is this a known bug? Something that I am doing wrong?

  2. general: there is zero feedback from selecting a wrong soundcard or any other configuration error. How about, when there is a startup issue, just mentioning it in plain sight in the Zythian app, instead of the app silently trying to reboot continuously? It would make it less a never-mind-it-just-doesn’t-work black box :wink: Even a location of a logfile in the manual would also be nice.

  3. in the preset-selection menu, sending a program change and playing notes does strrange things. Accidently I do this all the time, click a synth and start playing notes and sending control changes. The notes you will hear are from the selected preset on screen and the selected preset by program-change. Some apps immediately crash. I suggest not to do anything magical to force the visually selected preset to maintain (because this currently sometimes crashes), and just make the visual change for the new program change.


Lots of questions!

setBfree works for me in both stable and testing. What version are you running?

The apparently random changes of parameters is an issue I reported this week and am currently working on a solution.

It would be good to have more useful feedback in the error screen but that requires analysis of possible causes and a degree of intelligent diagnosis. There are maybe some hints that could be given, e.g. pointing to a wiki page that has common causes. You could submit a feature request.

I am not aware of the issue with MIDI adversely affecting preset screen (but can see why that might happen). I suggest submitting a bug report.

Let me start by telling I am so happy to see your reply, I lost a bit of hope on getting things fixed. Thanks!

I guess have the latest build from a month ago. Anywhere were I can read it out?

I will fire some bug/feature issues for everything else except the setbfree (plus a feature request about getting the build version :wink: ).

You can check version by connecting a web browser to webconf. You should see:


Raspbian GNU/Linux 10 (buster)
Build Date: 2020-09-25

Found: Build Date: 2021-09-25.

Are there any empty channel requirements for setbfree? I see it loves creating a lot of MIDI channels when I do choose others than Upper.

I am used to start the program setbfreeUI, and then instantly having a 1 MIDI-channel full-range great sounding organ. For extra experience, I click on some buttons (distortion and tremolo etc), maybe even add a few pipes (not required), and there I go, having my regular MIDI pedal for turning on/off the leslie. What things I have to do in Zynthian to get the same out-of-the-box experience that setbfreeUI gives?

Hi guys,
I have a similar crash issue when trying to use setBFree.
I loaded the latest stable SW (build date: 2021-09-25).
In the beginning everything was good. I added some snapshots, layers, played a little using both SetBFree and other layers.
But then, after a while, the UI hangs in the following scenario:
Starting fresh with no layer → add SetBFree - Hammond → select midi #1 → sine → upper+lower.
I hear the sound, but the UI is frozen.
I tried to do the same with reflashing the image to the SD card - similar results. It was good in the beginning, but after few hours i got to the same scenario.
Did anyone have a similar issue before? Thanks!!
Here is the screen which is stuck on:

Here is the log:

After flashing the sd card, did you wait (for several minutes) after first boot to ensure disk was resized and then performed update to get fixes since release?

Good point. I’ll reflash and folllow the above.