setBfree rotary's slow speed is working!

Perhaps some of you have noted that “slow speed” in the setBfree rotary (Hammond emulator) have never worked in Zynthian. A few times I’ve tried to solve the issue, but always failed.

Finally i realized that perhaps the problem wan’t in Zynthian software itself but in setBfree, so i opened an issue and … eureka!!. Mr. Robin Gareus (the setBfree main developer) has found and solved the problem. It was a precission related issue in the ARM architecture. You can read the full thread here:

The next zynthian update will include a patch for upgrading the setBfree. Those of you that can’t wait for enjoying the setBfree’s slow rotary in your Zynthian Box, can update by hand:

# cd /zynthian/zynthian-sw/setBfree
# git checkout .
# git pull
# sed -i -- "s/-msse -msse2 -mfpmath=sse/$CFLAGS $CFLAGS_UNSAFE/g" common.mak
# sed -i -- 's/^lv2dir = \$(PREFIX)\/lib\/lv2/lv2dir = \/zynthian\/zynthian-plugins\/lv2/' common.mak
# make clean
# make -j 3
# make install

Thanks, Robin!! :wink:



Thanks for brining the issue to my attention and helping to debug it! That’s very appreciated.

Brilliant, this was bugging me too, and I’d got no further than deciding it was some ARM thing.