Setup Zynthian for testing branch

This afternoon I dd a pull request based on the stable branch, since my Zynthian uses the stable branch and updated the code based on that one. Obviously Jose rejected the code to be merged directly in stable.

I have now looked for an easy way to setup Zynthian based on the testing branch. Looked in discourse, wiki and in the scripts.

What are you proposing as dev-friendly method?

ps: I found ‘’. However there is no option to pull/clone the testing branch.

You can change branches using the webconf.

It’s under ‘Software > Repositories’

You could navigate to the relevent directories on the cli and run git checkout <branchname> too I suppose

Thanks @Baggypants. Found and worked.

1 Like

I am a newbie, but enthusiastic about my Zynthian v5. How can I try/load the testing branch? Calling Repositories from the WebCon gave me:
500: Internal Server Error

Hi @Klangschmied !
I hope you are enjoying the V5.
Regarding your question, it shouldn’t fail. How is connected your Zyrthian to the internet?


1 Like

Enjoy the V5 very much, beside all other gear (norns, MOD Duo etc.)
Zynthian is connected via Ethernet cable to the Mac and the Mac is via WLAN on the internet.
Trying to connect V5 to my WLAN via WebCon, but no success, see picture

This is not going to work, my friend. Zynthian can’t access the network thru your mac, unless you configure your mac as a router, what is probably not the case. You must connect your zynthian to the network, by wifi or ethernet.

Wifi should work, but if it doesn’t, your only way is using an ethernet cable to the router.
BTW, where are you located? Germany?


1 Like

After your question, I thought, that may be the connection (cannot establish WLAN connection) is the problem :slight_smile:
How can I solve the WLAN connection problem, already searched in the forum, tried all suggestions, but nothing worked…

I am located in south Germany, near Stuttgart, exactly Ludwigsburg.

…tried your suggestion (Ethernet cable to the router) and it worked, I can see the Repos.

1 Like

Nice! I hope you got the testing version running :wink:

Another hint:
If I switch “Internet sharing” on for the Ethernet port on my Mac Mini, I can also see the Repos.
BTW The V5 is connected to the Mac via Ethernet cable, because the Wi-Fi connection does not work.

1 Like