Sfizz Integration

It should be fixed now. Update and test, please.


1 Like

Just trying out sfizz… does it install with a bunch of sfz sound banks, or do they need to be added manually? I can see the sfizz engine, but don’t get any sfz banks to choose from after that.

The official zynthian image include a good amount of SFZ files that should be available from sfizz.
Could you be more explicit about your case:

  • hardware
  • software version
  • how you updated
  • etc.


I’ve been running a slimline zynthian (rpi4, 4.3" touch screen and hifiberry dac/adc) on testing branch for the last few weeks with no issues.

Updating the software from within zynthian has added sfizz, but neither sfizz nor Linux sampler see the standard library of sfz presets. I can see them in webconfig so presumably they’ve not been deleted. I add a new layer, choosing sfizz or LS as the engine but it doesn’t then move on to the next screen where you’d get to select which bank/sfz to load.

sforzando soundfont archives work with SFIZZ! Just download, copy the archive over to the Zynthian (don’t use the gui) into the sfz softfont directory, untar or unzip it! It works! I just installed the Bear_Sax archive without doing anything in polyphone! This opens up a whole new set of HIGH QUALITY soundfonts. I have not done exhaustive testing with my EWI yet.

Just testing with my midi keyboard and pads for now.

1 Like

I have a question. I am trying to use the midi-fx multichord with a sfz harmonica soundfont. Chords are played but they are sustained. I can’t upload the soundfont, it’s too big. I’ll share the font by google drive later. Has anyone ran into this with multichord ? Do I need to add another MIDI-FX in parallel to fix it ?

Hi @Jerryn. I authored multi-chord. Well you describe the issue in more detail? You say it sustains. Do you mean that notes persist indefinitely? The code is hosted on GitHub so you could submit a bug report.

The notes are sustained for 30 seconds and stop. A panic all notes off isn’t required. It works with sf2 instruments, and worked with sfz. I just found a new high sample rate harmonica and was trying it with sfizz. Without multichord the notes on/off works fine. With multichord the behavior is like I am pressing a sustain peddle for 30 seconds. I didn’t think this could be considered a bug yet because I have only seen this with the new harmonica sfz. Later tonight I will post a link to the soundfont so you can try it. Maybe there’s a problem with the soundfont.

Hi Riban… I think multichord has a problem with SOME sfz soundfonts. NOT ALL, but it works with MANY. So I don’t know if it’s a bug or someone I need to do in the configuration.
Here’s the Harmonica,

And SquidPipes ( bagpipes ) It would be cool If I can play some AC / DC using the EWI for controlling the SquidPipes. My son plays guitar, he’s got a small band… for fun bass, drums, and two guitars. It would be cool if I take out the EWI and play SquidPipes :slight_smile:

SquidPipes are here:



ZynthianOS: Built on os.zynthian.org
Timestamp: 2020-09-05
Optimized: Raspberry Pi 3 Model B Plus

Kit: Custom
Display: Pi 7 Touchscreen Display 800x480
Soundcard: HifiBerry DAC+ ADC
Wiring Layout: DUMMIES
zynthian-ui: sfizz (6c7912)
zynthian-webconf: testing (38d33e)
zyncoder: testing (7b58d8)
zynthian-sys: sfizz (18d2a1)
zynthian-data: testing (f6a7b3)

I followed the guidance in this thread for the update in this thread.
Sfizz actually works GREAT :slight_smile:
I started to play around with multichord and just by chance I wanted to use multichord with
harmonica and SquidPipes. It works with just about everything else I tried LOL

Here’s the link to SquidPipes:

Here’s the link to the harmonica:

If anyone hasn 't examined the karoryfer.squidpipes in the sforzando player, it makes an interesting test case: The 3 diffferent programs each has a different set of controls and a different SFZ version requirement. The sforzando info lists the SFZ level.
01-squidpipes.sfz SFZ Level 2 with ARIA Extension - (ARIA is 57% implemented)
02-squidotron.sfz SFZ Level 2
03-squynth.sfz - SFZ Level 3 - (Level 3 nor even referenced in the Sfizz implementation notes)

03-squynth has the most complex controls: (I’m not finding SFZ v3 specs)
03-squynth Controls

sforzando player is not happy with the 2011 Harmonica files.
2 of 3 don’t make sound …
Harmonica Vibrato has an extreme square wave modulation.
Harmonica Vel Switch errors:
<#18> Unknown Opcode: amplfo_freqccnan=0
<#40> Unknown Opcode: amplfo_freqcc&.&=0
Looks like Sfizz has the edge in this case.

I get an error loading sfizz engine:

Aug 28 10:33:45 zynthian1 startx[513]: ERROR:zynthian_gui_layer.add_layer_midich: local variable 'f' referenced before assignment

This happens after:

  • New synth layer
  • Sfizz - SFZ player
  • MIDI CH#1

I am presented with:

Squidpipes and Harmonica work fine on the Zynthian. With a midi keyboard you can make it sound like bagpipes… playing chords manually. Tonight I will try it with the EWI. Today I am driving out to my r/c clubs field and flying a few of the models I built


`type or paste code here`

After the update when switching to the sfizz repo I reinstalled sfizz with the Zynthian recipe, as stated in the thread. Also I am using a combo of the testing and sfizz repos. Testing where sfizz doesn’t apply.

Ahh! My morning coffee kicked in. I remember now! I ran into this and thought it was due to me booting and running my Zynthian entirely from ssd. I updated envars and Zynthian sys boot config files, and disabled usb automount. I thought that the reason why the sound files didn’t appear was that I missed an envar requirement change. As a quick fix I just copied the SFZ data to zynthian-my-data/soundfotns/sfz , and it worked.

I reinstalled sfizz and am getting the same error. it looks like it could be an error in the sfizz engine python code. I am too busy barrowing 3.5 tonnes of hardcore today to diagnose. Maybe @jofemodo could check for this error?

Sorry guys! My fault. This bug is fixed now.


FYI, “sfizz” branch is merged on “testing”, so those of you already on “sfizz” should switch-back to “testing” ASAP.


Yay! I got it working (on testing). Maybe I can look at the issue with multi-chord… but not today - I am going to a festival! Yes - lockdown is breaking and we can go outside and hear live music again. Blessed be the day!


Will you be dancing, topless, on somebodies shoulders…?