Should have known better, I think :(

I haven’t used my Zynthian k3-pro in a while. So I ran software update on the Zynthian but it looked like many things failed. Next I burnt a new image onto a new SD card (latest image from the wiki.

Zynthian immediately started but gave me the red ERROR IP: message. I logged in, nonetheless from the webconf page and updated my wireless network. And I ran software update. Everything seemed to go just fine.

Now my Z starts and gives me the red ERROR message along with the IP address I use for the webconf page.

When I reboot I continue to get the error message. Basically, this is all I did

  1. Connect your Zynthian Box to your router/switch using an Ethernet RJ45 cable. Alternately, you can configure the WIFI connection using the Webconf tool.
  2. Click update software from the UI’s Admin Menu
  3. Click restart UI (or reboot) from the UI’s Admin Menu

while connected through ethernet to an extender that’s wired to my router.

If someone could set me straight I’d be very grateful!

Thanks in advance,


… I can also ssh into root@ip_num


aplay -L suggests that Zynthian isn’t seeing my Hifiberry DAC+ADC Pro, even though the web interface sees it?

root@zynthian:~# aplay -L
Discard all samples (playback) or generate zero samples (capture)
bcm2835 Headphones, bcm2835 Headphones
Default Audio Device
bcm2835 Headphones, bcm2835 Headphones
Default Audio Device
bcm2835 Headphones, bcm2835 Headphones
Direct sample mixing device
bcm2835 Headphones, bcm2835 Headphones
Direct sample snooping device
bcm2835 Headphones, bcm2835 Headphones
Direct hardware device without any conversions
bcm2835 Headphones, bcm2835 Headphones
Hardware device with all software conversions

You have to set up your hardware with the web configuration tool.

Off topic : “I should have known better” is a song from the excellent post punk band Wire :brown_heart:

1 Like

Yes, the newer image defauls to the V4 kit so you need to set it to V3.

1 Like

Le51: Will have to check that song out!! (Thanx!) “I should have known better” is my dumb reference to I should RTFM!

BP: I did use the webconf tool and even after the error message the summary page looks like all is well. (I have a prebuilt v3 system with the DACADC Pro and that’s the system I configured with the web tool).

Am going to reflash card and RTFM and try all over again with no presuppositions … sometimes that can help! (All advice or comments still welcome!)

Well, now I do know better :slight_smile:

Step 1: RTFM and LISTEN and be sure you understand advice given to those who helpfully answer questions.

Step 2. Having read the manual, do as it says in the order it says to do so.

Step 3. If things go wrong, say with the IP error message, look to see if that’s mentioned in the manual (the wiki that serves as the manual).

Having now followed those 3 steps I have an updated fully-configured Zynthian that works as it was designed to work! (Thanks Zynthian team!)



:+1: :+1:… and :face_with_monocle: