Snapshots and update problem

I have a problem with my Zynthian. Last week I’ve noticed that arised a problem with snaphot of ZynAddSubFX settings (other engines save properly). All seems ok until rebooting. Saved ZynAddSubFX snapshots disappear.
I’v thought that it is caused by a broken sd card so I’v instaled new edge image. On fresh install this happen also.
Thinking that it is a bug or something i’v tried to update. And after update Zynthian do not start. After Zynthain splash screen all is shutting down.
I’v tried several times on different sd cards - it’s still the same.
Few days (or weeks) ago all was good (snapshots saved and load properly).
What you think it may be? A hardware problem?

You need to isolate the problem.
And we need output traces.
I read, that you can’t ssh into the zynthian either, because it is shutting down too early?

Try the image without screen and soundcard. And build it up one by one component.

Update issue has minor importance. The ZynAddSubFX engine snapshot disappearing is my headache. I can ssh. I have constructed my Zynthian by myself and i think that soundcard and screen is ok but i’m rather software noob and i do not know what should I check in ssh session.

One thing more. The ZynAddSubFX snapshot does not disapear when I shut down Zynthian from the menu. When I simply pull the power suply this strange things happen.

Hi @ejdzi!

Have you solved your problems? Did you make some improvement?



The updating problem disapear. But still there is an issue with saving snapshots and powering off Zynthian. When I simply pull the cable the new saved snapshot disapear. When I close Zynthian from menu everything is ok. But this is not a problem. Just need to remember :slight_smile: Thanx. Regards. Adam

Hi @ejdzi!

The problem should be fixed. Now “sync” is called after saving snapshots, so you could unplug your zynthian safely without losing your last changes. Same applies for “saving” config from webconf and other “write” operations, like recording audio.