Software Upgrade Failed


#1

Hi. I have just built my Zynthian and (yesterday) it worked. I am very impressed with the whole concept and am excited to be part of this project. Thank you

However today I did an “update software” and now I am getting server error 500 on most of the webconf UI pages.

Any suggestions?

David


SOFTWARE UPGRADE "Multilayer"
#2

Try to stop the service
systemctl stop zynthian-webconf

And run it manually in
/zynthian/zynthian-webconf

./zynthian_webconf.sh

Now you should be able to tell us the reason for the 500 message.


#3

OK. I get the Python error message:

FileNotFoundError: [Errno 2] No such file or directory: ‘/zynthian/zynthian-ui/my-data/midi-profiles/default.sh’

I looked and there is no directory called /zynthian/zynthian-ui/my-data/
I tried to run MIDI profile on the UI, just to see if it would be created, but it wasnt there. However there IS a file called /zynthian/zynthian-my-data/midi-profiles/default.sh

Looks like the python script is out of synch with the filestore?
I could copy the data across but not sure if that will break other things!

David


#4

Looks like its hardcoded:

            fpath=os.environ.get("ZYNTHIAN_SCRIPT_MIDI_PROFILE",
                    os.environ.get("ZYNTHIAN_MY_DATA_DIR", "/zynthian/zynthian-my-data") + "/midi-profiles/default.sh")

#5

Hi @mottdh!

Something seems to failed while updating and the MIDI profile directory wasn’t created correctly.
Try updating again and it should fix the problem.

If it doesn’t work, you should try to re-burn your SD-card and update again.

Kind Regards,


#6

I have the same problem, its the fifth time I have to reburn and update the SD-card.
I’m getting ERROR:tornado.application:Uncaught exception POST /api/ui-midi (192.168.1.10)
After saving any midi value in the webconfig.


#7

Have you updated webconf only? You need to git pull zynthian-ui as well