[Solved] MIDI learn not working anymore

OK, I mark this as solved. The problem is that it seems to work in a different way than it is explained in the WIKI: If I touch and hold a controller, I do get the green ?? and can assign a MIDI CC channel, but using “Learn” is not working.

I cannot use MIDI learn anymore. Not sure what happened, but when I touch “Learn”, the yellow ?? appear, but moving any controller on the touchscreen does not make them turn green. I cannot see any errors in the logs. I tried with different plugins (Shiroverb, MVerb, ALO) and none of them is able to use MIDI learn.
I am using a Pi4 with a touchscreen connected to it and I used to be able to use MIDI learn with the touch screen. After I discovered that problem I ran software update, but the problem is still there.

Hi, How did you solve this? I have exactly the same issue.

Have you tried using the touchscreen to activate the midi learn? I think it is available if you swipe right inside the lower half of the parameter box you wish to assign. The green ?? should show up immediately, skipping the yellow ?? step.

It turns out the wiki has been wrong (says green ?? for first step, then yellow ??) even though the screenshots show the opposite. I think that has been wrong for a long time :joy:. I fixed that now.

edit: don’t know left from right!
It’s updated (using touch/mouse to assign midi) in the wiki: Zynthian UI User Guide - V1/V4 - ZynthianWiki


I only tried to follow the instructions initially.
Now I used this gesture — and it works! I can assign a nanoKontrol fader to a parameter.
Thank you a lot.

1 Like