SOLVED: Zynthian v4.6 touchscreen calibration issue


I just purchased a new (to me) used Zynthian v4.6 from eBay. The kit is already assembled and everything appears to be working as it should except for the touchscreen. It is not properly calibrated.

I am using a stylus, and I have located the Calibrate Touchscreen function in the Admin menu. I can accurately touch the 3 crosshairs; however, once I’m in the OS, the touch selection is very inaccurate. In some ways, it seems almost inverted (i.e. if I tap on the bottom of the screen, a menu item on the top is selected and vice versa). I’ve tried “fooling” the Calibrate Touchscreen function by tapping on areas outside the crosshairs, but it doesn’t seem to do much (it may not be doing anything, in fact).

This is brand new to me and I am still learning. I’ve checked the 4.6 build guide and there doesn’t seem to be anything about touch calibration. I’ve not yet opened the case, but I am fairly certain that this is an official kit using the stock display that Zynthian would have sent.

In short, can anyone give me some guidance on how I might get this display properly calibrated? Thanks in advance for any assistance!

Edit: It appears that the 3 crosshairs turn from white to red (meaning you’ve selected/tapped them) no matter where you touch the screen. I initially thought the screen was somehow calibrated while in the Calibrate Touchscreen mode and not calibrated while in the OS, but I now believe it is just not calibrated at all regardless of the screen/mode.

Edit (again): found out how to access zynthian.local. It shows I’m using ZynScreen 3.5 (v1) 480x320 with the following config:


Edit (final): alright, feeling a little dumb. Found calibration notes on the wiki and it says to tap and drag to the middle of the crosshairs (instead of just tapping them individually). Doing this gets me much better calibration, though it is still slightly off. I’m marking this a solved, but if any one has additional guidance, please feel free to share.

1 Like

Hi @Diffrentstrolks !

Welcome to zynthianland. I hope you enjoy the zynthian v4! Please, don’t hesitate to share your doubts and thoughts with us.

What software version are you using? Is it the last stable? Testing perhaps? Is it updated to the last?
I remember there was some fix about touch calibration some months ago, so if your image is not the last stable, i would recommend to download and burn the latest one, or try updating.


Hello! Thanks for the reply. Yes, after my last edit/update I found out that I was on a pretty old software version (v2109, I think it was). I was definitely wondering why the manual/wiki was not matching up at all with what I was seeing (i.e. chains vs. layers, no mixer screen, etc).

I spent some time updating/burning to the latest stable release and calibration is much much better. I’d say this thread/issue is officially solved.

Thanks again; now time to enjoy the Zynth!


There is no easier way of enjoying a zynth than this …