SooperLooper - In Testing

Perhaps I’m commenting in the wrong category, but I have an issue related to sooperlooper.
When using Zynthian version from 2022, Sooperlooper worked fine.
I’ve recorded 5-10 instruments (various zynthian gig sampler instruments), looped, overdubbed etc.
Yesterday I’ve managed to install latest stable version.
Now when adding sooperlooper I get an error: Error CUIA zynswitch 3,5.
If I try to add sooperlooper 1 or 2 more times Zynthian freezes, displaying “Adding chain”.

After you installed latest stable version did you do a software update? It might fix it, and is probably a good idea anyway.

1 Like

Yes I did and it didn’t help.
I went back to a 32bit stable version for now. :slight_smile:

1 Like

I just tested sooperlooper in Oram and it works. There was a period when it wasn’t working because Sooperlooper binary hasn’t been added to the build but an update should fix that. We need to understand why it is failing for you.

1 Like

I need to buy another SD card and make an image of the working setup I have right now, before I try 64bit version again.
I want to be able to switch to working environment quickly.
Can you please send my a link to a semi fresh 64bit Zynthian image?
I’ll try it as soon as I have a backup.

Thank you!

1 Like

I put sooperlooper on an audio+midichannel (channel 3)
I put zynadsubfx on an chain with midichannel 3(midiforwarding is not working)
I put linuxsampler on a chain with midichannel 3.

made a subsnapshot with sooperlooper selected and linuxsampler muted. I mapped these to programchange 1 on my keyboard
I made a subsnapshot with sooperlooper selected and zynadsubfx muted. mapped to progch 2.

This workflow worked for one day. Now every time i press progch 1, sooperlooper resets.

I’m using bookworm, updated it last wedsnesday.

Is there a way to work with sooperlooper, recording different channels on the Zynthian? And can someone describe the workflow?

Thank you for that.

So, maybe I want to much. I want to use a zynthian as a synthesizer and a loopstation. This guy only uses one instrument on Zynthian. I want too use more instruments on Zynthian.

within sooperlooper I want to press progch 1 and play Zynaddsubfx, , and then press progch 2 and play piano. Is that possible?

It seemed to be working, but sooperlooper restarts when I send a progchange. Is that a bug, or I’m I pushing it too hard?

Hi @robert !

I don’t think you are pushing too much. It should work. Let me check with your snapshot. Please attach it.

Anyway, why not placing sooperlooper in the main bus? It seems a better place if you plan to change instruments while looping.
Also, are you using ACTI or MULTI mode for your input devices? How many input devices do you have? Etc.


This workflow is not what i would do. How is routed audio?
I would do something like this:

  • SooperLooper in the Main Bus. MIDI-learn sooperlooper controls using absolute MIDI learn (controller/learn options submenu), so you can control it regardless of the selected chain. Should we force absolute MIDI learn on Main Bus, @riban?

  • Chain with ZynAddSubFX: channel 1

  • Chain with LinuxSampler: channel 2

  • etc.

If you want to layer sounds, then use the same MIDI channel for them and enable “Active MIDI channel” from admin menu.

If you use a single keyboard for playing, set ACTI mode for it. Then learn your ZS3s.


I’ve ordered a spare SD card. Will try Oram again in a few days.

I didn’t know there was a function called absolute midi learn. I’ll check it out. But at the moment I’m using the v5 buttons to control it.

But still… How do I change the active layer when I’m in the sooperlooper GUI?

You can’t. Active layer is always the displayed/gui-controlled layer.


No! A user may have a MIDI controller that they use to control the currently selected processor, e.g. ADSR on a synth and Compressor in main mix bus.

I cannot find this option anywhere. I searched the forum and the wiki pages. webconf. It is mentioned at some places, but never explained.

Ok thanks,
That’s why I put it in an audio/midi channel. So I can control everything from there. I 'd rather have my eyes on sooperlooper than on the synth.

But maybe I can learn to live with that.
Any advice on how to find the absolute midi learn would be really appreciated.

If you have V5, you click a knob for “chain midi learn”, a second click for global/absolute midi learn.

If you don’t have V5, you must access the midi learn submenu.


1 Like

I was working on this and have improved access to global MIDI learn from classic layouts and touch interfaces. Please, note that global MIDI learn is specific to Oram.

Classic layouts with knobs at corners

  • Click knob#3 (learn) to enter MIDI learn mode. The green “??” should be displayed on every controller.
  • Click knob#3 again to enter Global MIDI learn mode. The yellow “??#??” should be displayed on every controller.
  • Move the desired controller to select it. The selected controller will remain with the yellow “??#??”.
  • Move the knob in your MIDI controller to bind globally (absolutely).

Touch interface

  • From chain options, select “MIDI learn- > Enter Global MIDI learn”. The yellow “??#??” should be displayed on every controller.
  • Touch the desired controller. The selected controller will remain with the yellow “??#??”.
  • Move the knob in your MIDI controller to bind globally (absolutely).

Mental note for docu writers: This should be added to the wiki’s oram documentation :wink:



I think I found a solution that works for me. To control Sooperlooper with global controls works indeed, but I would like to keep my eyes on the interface. Just to be sure I hit the right button, and to see in what track I am recording.
So putting Sooperlooper in main bus is not working for me, because I cannot control the mixer anymore.
But I found out that you can edit a ZS3 subsnapshot to only update the mixer, and leave the rest alone.
So I’m back to my first try:

Sooperlooper in an audio/miditrack and forwarding all midi to the synths in other tracks.
Audio routed back to sooperlooper.
And all synths I don’t want to hear muted, exept for the one I’m using.

But now I can look at the sooperlooper screen and change instruments while recording.