Stable-2211 & Raspberry Pi 3 performance

After reading about the new stable I reactivated my custom build Zynthian, but sadly I am encountering massiv xruns, especially in the new mixer view. In its current state my Zynthian is not usable with the stable-2211. I already tinkered with the audio configuration, but to no avail.

What are your experiences, does anyone run the stable-2211 smoothly on an raspi3 - and if yes, how did you make it?

btw I’ve got a Raspberry Pi 3 Model B Rev 1.2 with a HifiBerry DAC+ ADC and a WaveShare 3.5B V2 connected together by a handwired Midi/MCP23017 circuit board powered by a 3A supply

I tested the new stable in a old v1 zynthian (RBPi3 + Hifiberry DAC+) and it worked normally. I mean i didn’t find the performance was worst than before.
I thinbk @riban also tested quite a bit with RBPi3, so perhaps he could tell about his feeling.


I did most of the development on a RPi3 and some final testing so it sounds like something odd in your build. I’m not at home to test with a RPi3 for at least a month ago can’t do any physical tests now.

yepp, seems so - although soundcard is configured correctly (test plays fine) I immediatly get xruns rolling as soon as I enter mixer view (without even adding a channel) and after a while the encoders stop working or the ui freezes.
Think I will rebuild it step by step starting with the PSU until I find where I messed up. I designed the circuit boards myself, perhaps it would have been a better idea to use the zynaptik or the allinone board - but it was a lot of fun.

Pi 3, standard Raspi power supply, Hifiberry DAC / ADC pro, standard 7 inch touchscreen with a Behringer X-Touch mini as controller. Everything works like a charm. The Pi has no problems powering the Behringer controller, a USB MIDI interface and a Roland SH-01A synth via USB.
I am very glad with this latest version. Finally MIDI is working with the Roland. The device now showing up as “Boutique”.

Is VNC enabled? This can impact performance. You can also disable the peak program meters for the chains which will save some processing but as others have said, it should work and certainly be able to display an empty mixer. Check CPU and temperature and look out for undervoltage and high temperature indication (which look similar to the xrun indication).

thanks for the suggestions @riban - but I’ve already everything disabled that is not necessary and they are definitly xruns (no undervoltage or temp warnings) - I can see them in the logs. I suppose there is some flaw in my hardeware wiring which causes the raspi to choke. Bit puzzling, normally something works or it doesn’t but these ‘floating’ bugs are hard to find. As I said, I will start with a barebone installation and work my way up. At least I know now that the raspi 3 should be able to handle the update well. I was concerned that stable-2211 needs a raspi 4 to work properly and these creatures are a rare breed nowadays.

… and after all now that the soldering iron already is plugged in I am thinking about combining the expression pedal with an Arduino powered footswitch board to control sooperLooper :smile:

1 Like

Another thing to check is whether “Route MIDI to Output Ports” is enabled in webconf INTERFACE->MIDI Options. There is a bug that can result in MIDI howl-round which can lead to the behaviour you describe.