Time for the Buster RC-3 SD image

Hi @zynthianers!

I think it’s time to release the Buster RC-3 SD image. Let’s start with:


Stop downloading and testing this image. It’s not workig OK…

and report to this thread …


1 Like

BTW, last nightly builds have default assignment for the 4 extra switches:

  • S1 => MIDI Program Change 1
  • S2 => MIDI Program Change 2
  • S3 => MIDI Program Change 3
  • S4 => MIDI Program Change 4

It’s only a starting point. I hope to make more self-contained the ZS3 (subsnapshots) functionality.


Hi :slight_smile:
Is it to be considered the new default stable version, then?

No. We have to test it to be sure all the functionality is working OK on it. If some problem is detected, it will be fixed and a new build will be proposed.


1 Like

Installed it today, basics seem ok - will give it some proper testing in a bit.

Don’t forget to test the surge engine with the 2 only presets available. It should work …


Well, I tried it on my Zynthian Kit 4 (Pi4) and it doesn’t work for me… (exactly the same issue as I had with snapshots newer than rc2): the screen doesn’t come on at all. Clean flash of the image, straight boot. The zynthian.sh can’t find the screen and it never powers on.

Webconfig works and I can login, so I could troubleshoot if there is any interest, otherwise I’ll have to flash back to rc2 again (and probably get a second sd card for a stable version…).

From the webconfig UI log I see the same error:
./zynthian.sh: line 55: /sys/class/backlight/*/bl_power: No such file or directory (note that this error didn’t occur on rc2 and the screen worked fine)

root@zynthian:~# cd /sys/class/backlight
-bash: cd: /sys/class/backlight: No such file or directory

it seems that it doesn’t load the driver for the screen or something…
any pointers apppreciated to help troubleshoot this.

EDIT: I’ve reflashed to rc-2, which powers the screen on without issue, and will allow me to make some music. (I can’t help in testing or troubleshooting this issue further, but I do hope it gets solved or I’m stuck on rc-2, or it’s another issue…). I’m getting a second SD card to keep a stable ‘known working’ version around.

1 Like

Surge is a synth layer? It’s not showing for me.

Btw, I did a totally clean install on a Raspberry Pi 4 if that helps for @twelve. I had some strange issues upgrading with the last build too - for me layers wouldn’t load but this is working much better.

New V4 just build yesterday…
Screen was okay (but not detect my USB MIDI Keyboard) with the buster RC2…
RC3 in test now, and I get no more screen !

Here is the log from WEBUI, for the UI LOG:

-- Logs begin at Fri 2020-08-07 09:30:28 BST. --
Aug 07 09:31:17 zynthian startx[1141]: (==) Log file: "/var/log/Xorg.0.log", Time: Fri Aug 7 09:31:17 2020
Aug 07 09:31:17 zynthian startx[1141]: (==) Using config directory: "/etc/X11/xorg.conf.d"
Aug 07 09:31:17 zynthian startx[1141]: (==) Using system config directory "/usr/share/X11/xorg.conf.d"
Aug 07 09:31:18 zynthian startx[1141]: ./zynthian.sh: line 55: /sys/class/backlight/*/bl_power: No such file or directory
Aug 07 09:31:19 zynthian startx[1141]: error: failed to open file /zynthian/zynthian-plugins/lv2/Surge.lv2/manifest.ttl (No such file or directory)
Aug 07 09:31:19 zynthian startx[1141]: lilv_world_load_file(): error: Error loading file `file:///zynthian/zynthian-plugins/lv2/Surge.lv2/manifest.ttl'
Aug 07 09:31:19 zynthian startx[1141]: lilv_world_load_bundle(): error: Error reading file:///zynthian/zynthian-plugins/lv2/Surge.lv2/manifest.ttl
Aug 07 09:31:20 zynthian startx[1141]: libjackpeak registering as 'jackpeak'.
Aug 07 09:31:20 zynthian startx[1141]: libjackpeak created input ports
Aug 07 09:31:21 zynthian startx[1141]: ERROR: PatternManager failed to open file for load /zynthian/zynthian-my-data/sequences/patterns.zynseq

no Generic HDMI display with my RC3 also…

Still testing !

same for me

Ah, happy to see that somebody is confirming the same issues as I had, that means that the odds are raised that this image most likely won’t work out of the box with a v4 kit for now. (and the odds are lowered ever so slightly it’s a hardware issue on my side)

I hope it can be reproduced :slight_smile:

Now here’s one for the clever among you. How in an entirely Pi infrastructure like what zynthian Towers have recently become do I burn images…?

This issue, jitsi chat’s with castle riff raff, and Nord Modular GUI’s are the only thing keeping my old laptop alive. . .?

Normal castle rewards apply for solution of such problems.

You get fed next week.

What do you get from this command:

tree  /sys/class/backlight


root@zynthian:~# tree  /sys/class/backlight
    /sys/class/backlight [error opening dir]

    0 directories, 0 files

and this?

root@zynthian:~# lsmod
Module                  Size  Used by
nft_counter            16384  1
xt_DSCP                16384  1
xt_tcpudp              16384  1
nft_compat             20480  2
nf_tables             143360  6 nft_compat,nft_counter
nfnetlink              16384  2 nft_compat,nf_tables
snd_seq_dummy          16384  2
snd_hrtimer            16384  1
snd_seq                69632  6 snd_seq_dummy
snd_seq_device         16384  1 snd_seq
8021q                  32768  0
garp                   16384  1 8021q
stp                    16384  1 garp
llc                    16384  2 garp,stp
evdev                  24576  1
joydev                 20480  0
snd_soc_pcm512x_i2c    16384  1
snd_soc_pcm512x        32768  1 snd_soc_pcm512x_i2c
fb_ili9486             16384  1
snd_soc_pcm186x_i2c    16384  1
snd_soc_pcm186x        24576  1 snd_soc_pcm186x_i2c
fbtft                  36864  1 fb_ili9486
regmap_i2c             16384  2 snd_soc_pcm186x_i2c,snd_soc_pcm512x_i2c
syscopyarea            16384  1 fbtft
sysfillrect            16384  1 fbtft
sysimgblt              16384  1 fbtft
fb_sys_fops            16384  1 fbtft
ads7846                24576  0
brcmfmac              319488  0
brcmutil               16384  1 brcmfmac
sha256_generic         16384  0
libsha256              20480  1 sha256_generic
cfg80211              679936  1 brcmfmac
rfkill                 28672  4 cfg80211
spi_bcm2835            24576  0
bcm2835_isp            32768  0
bcm2835_v4l2           45056  0
bcm2835_codec          36864  0
videobuf2_vmalloc      16384  1 bcm2835_v4l2
bcm2835_mmal_vchiq     28672  3 bcm2835_isp,bcm2835_codec,bcm2835_v4l2
snd_soc_bcm2835_i2s    16384  2
snd_soc_hifiberry_dacplusadcpro    16384  4
v4l2_mem2mem           32768  1 bcm2835_codec
videobuf2_dma_contig    20480  2 bcm2835_isp,bcm2835_codec
videobuf2_memops       16384  2 videobuf2_dma_contig,videobuf2_vmalloc
videobuf2_v4l2         28672  4 bcm2835_isp,bcm2835_codec,bcm2835_v4l2,v4l2_mem2mem
videobuf2_common       57344  5 bcm2835_isp,bcm2835_codec,bcm2835_v4l2,v4l2_mem2mem,videobuf2_v4l2
snd_soc_core          200704  4 snd_soc_pcm512x,snd_soc_pcm186x,snd_soc_bcm2835_i2s,snd_soc_hifiberry_dacplusadcpro
snd_bcm2835            24576  2
snd_compress           20480  1 snd_soc_core
snd_pcm_dmaengine      16384  1 snd_soc_core
snd_pcm                98304  9 snd_soc_pcm512x,snd_soc_pcm186x,snd_pcm_dmaengine,snd_soc_bcm2835_i2s,snd_bcm2835,snd_soc_core,snd_soc_hifiberry_dacplusadcpro
raspberrypi_hwmon      16384  0
videodev              237568  6 bcm2835_isp,bcm2835_codec,videobuf2_common,bcm2835_v4l2,v4l2_mem2mem,videobuf2_v4l2
snd_timer              32768  3 snd_seq,snd_hrtimer,snd_pcm
mc                     45056  6 bcm2835_isp,bcm2835_codec,videobuf2_common,videodev,v4l2_mem2mem,videobuf2_v4l2
snd                    73728  19 snd_compress,snd_soc_pcm512x,snd_seq,snd_timer,snd_seq_device,snd_bcm2835,snd_soc_core,snd_pcm
vc_sm_cma              32768  2 bcm2835_isp,bcm2835_mmal_vchiq
i2c_bcm2835            16384  1
rpivid_mem             16384  0
uio_pdrv_genirq        16384  0
uio                    20480  1 uio_pdrv_genirq
clk_hifiberry_dacpro    16384  1
i2c_dev                16384  2
ip_tables              28672  0
x_tables               32768  4 ip_tables,nft_compat,xt_tcpudp,xt_DSCP
ipv6                  450560  26
nf_defrag_ipv6         20480  1 ipv6

And this?

systemctl stop zynthian
root@zynthian:~# systemctl stop zynthian
root@zynthian:~# zynthian.sh

X.Org X Server 1.20.4
X Protocol Version 11, Revision 0
Build Operating System: Linux 4.15.0-99-generic armv8l Raspbian
Current Operating System: Linux zynthian 5.4.51-v7l+ #1332 SMP Tue Aug 4 18:40:14 BST 2020 armv7l
Kernel command line: coherent_pool=1M 8250.nr_uarts=1 snd_bcm2835.enable_compat_alsa=0 snd_bcm2835.enable_hdmi=1 snd_bcm2835.enable_headphones=1 bcm2708_fb.fbwidth=640 bcm2708_fb.fbheight=480 bcm2708_fb.fbswap=1 smsc95xx.macaddr=DC:A6:32:64:F5:96 vc_mem.mem_base=0x3ec00000 vc_mem.mem_size=0x40000000  dwc_otg.lpm_enable=0 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait
Build Date: 07 July 2020  09:38:51PM
xorg-server 2:1.20.4-1+rpt2 (https://www.debian.org/support) 
Current version of pixman: 0.36.0
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Fri Aug  7 15:38:18 2020
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
./zynthian.sh: line 55: /sys/class/backlight/*/bl_power: No such file or directory
INFO:zynthian_gui_config.<module>: ZYNTHIAN-UI CONFIG ...
INFO:zynthian_gui_config.<module>: Wiring Layout MCP23017_ZynScreen
DEBUG:zynthian_gui_config.<module>: ZYNCODER A: [102, 105, 110, 113]
DEBUG:zynthian_gui_config.<module>: ZYNCODER B: [101, 104, 109, 112]
DEBUG:zynthian_gui_config.<module>: SWITCHES layout: [100, 103, 108, 111, 106, 107, 114, 115]
DEBUG:zynthian_config.get_disabled_midi_in_ports: DISABLED_MIDI_IN = ['']
DEBUG:zynthian_config.get_enabled_midi_out_ports: ENABLED_MIDI_OUT = ['ttymidi:MIDI_out']
DEBUG:zynthian_config.get_enabled_midi_fb_ports: ENABLED_MIDI_FB = ['']
DEBUG:zynthian_gui_config.set_midi_config: MMC Bank Change CCNum: 0
DEBUG:zynthian_gui_config.set_midi_config: MMC Bank Change UP: None
DEBUG:zynthian_gui_config.set_midi_config: MMC Bank Change DOWN: None
DEBUG:zynthian_gui_config.set_midi_config: MMC Program Change UP: None
DEBUG:zynthian_gui_config.set_midi_config: MMC Program Change DOWN: None
error: failed to open file /zynthian/zynthian-plugins/lv2/Surge.lv2/manifest.ttl (No such file or directory)
lilv_world_load_file(): error: Error loading file `file:///zynthian/zynthian-plugins/lv2/Surge.lv2/manifest.ttl'
lilv_world_load_bundle(): error: Error reading file:///zynthian/zynthian-plugins/lv2/Surge.lv2/manifest.ttl
INFO:zynthian_gui.<module>: STARTING ZYNTHIAN-UI ...
INFO:zynthian_gui_keybinding.load: Loading key binding from keybinding.yaml
DEBUG:zynthian_gui_keybinding.load: Loading keyboard binding config file '/zynthian/config/keybinding.yaml' =>
enabled: true
    modifier: 0
    keysym: Space
    modifier: 1
    keysym: Space
    modifier: 4
    keysym: Space
    modifier: 1
    keysym: Home
    modifier: 4
    keysym: Home
    modifier: 4
    keysym: End
    modifier: 4
    keysym: Insert
    modifier: 0
    keysym: Return, Right
    modifier: 1
    keysym: Return, Right
    modifier: 4
    keysym: Return, Right
    modifier: 0
    keysym: BackSpace, Escape, Left
    modifier: 1
    keysym: BackSpace, Escape, Left
    modifier: 4
    keysym: BackSpace, Escape, Left
    modifier: 0
    keysym: l
    modifier: 1
    keysym: l
    modifier: 4
    keysym: l
    modifier: 0
    keysym: s
    modifier: 1
    keysym: s
    modifier: 4
    keysym: s
    modifier: 0
    keysym: Up
    modifier: 0
    keysym: Down
    modifier: 2
    keysym: Up
    modifier: 2
    keysym: Down
    modifier: 1
    keysym: Up
    modifier: 1
    keysym: Down
    modifier: 4
    keysym: Up
    modifier: 4
    keysym: Down
    modifier: 0
    keysym: a
    modifier: 1
    keysym: a
    modifier: 8
    keysym: a
    modifier: 4
    keysym: a
    modifier: 5
    keysym: a
    modifier: 12
    keysym: a
    modifier: 0
    keysym: m
    modifier: 1
    keysym: m
    modifier: 8
    keysym: m
    modifier: 4
    keysym: m
    modifier: 5
    keysym: m
    modifier: 12
    keysym: m

libjackpeak registering as 'jackpeak'.
libjackpeak created input ports
INFO:zynthian_gui.zynswitches_init: SWITCHES INIT...
INFO:zynthian_gui.zynswitches_init: SETUP ZYNSWITCH 0 => wpGPIO 100
INFO:zynthian_gui.zynswitches_init: SETUP ZYNSWITCH 1 => wpGPIO 103
INFO:zynthian_gui.zynswitches_init: SETUP ZYNSWITCH 2 => wpGPIO 108
INFO:zynthian_gui.zynswitches_init: SETUP ZYNSWITCH 3 => wpGPIO 111
INFO:zynthian_gui.zynswitches_init: SETUP ZYNSWITCH 4 => wpGPIO 106
INFO:zynthian_gui.zynswitches_init: SETUP ZYNSWITCH 5 => wpGPIO 107
INFO:zynthian_gui.zynswitches_init: SETUP ZYNSWITCH 6 => wpGPIO 114
INFO:zynthian_gui.zynswitches_init: SETUP ZYNSWITCH 7 => wpGPIO 115
INFO:zynthian_gui.zynswitches_midi_setup: MIDI SWITCHES SETUP...
INFO:zynthian_gui.zynswitches_midi_setup: MIDI ZYNSWITCH 4: DISABLED!
INFO:zynthian_gui.zynswitches_midi_setup: MIDI ZYNSWITCH 5: DISABLED!
INFO:zynthian_gui.zynswitches_midi_setup: MIDI ZYNSWITCH 6: DISABLED!
INFO:zynthian_gui.zynswitches_midi_setup: MIDI ZYNSWITCH 7: DISABLED!
INFO:zynthian_engine.start: Starting Engine JackTransport
DEBUG:zynthian_engine.start: Command: /usr/local/bin/jack_transport
INFO:zynthian_gui_admin.stop_rbpi_headphones: STOPPING RBPI HEADPHONES
DEBUG:zynthian_engine_mixer.get_controllers_dict: MIXER CTRL LIST: ['Digital', 'ADC', 'ADC Left Input', 'ADC Right Input']
DEBUG:zynthian_engine_mixer._send_controller_value: amixer -M -c sndrpihifiberry set 'Digital' 'Playback' 100% unmute
zynseq: Jack samplerate: 44100
zynseq: Jack buffer size: 256
ERROR: PatternManager failed to open file for load /zynthian/zynthian-my-data/sequences/patterns.zynseq
DEBUG:zynthian_engine_mixer._send_controller_value: amixer -M -c sndrpihifiberry set 'ADC' 'Capture' 9% unmute
INFO:zynthian_gui.osc_init: ZYNTHIAN-UI OSC server running in port 1370
ZynMidiRouter: MIDI tuning frequency set to 440 Hz (8192)
INFO:zynthian_gui_admin.stop_midi_clock: STOPPING MIDI CLOCK
DEBUG:zynthian_engine_mixer._send_controller_value: amixer -M -c sndrpihifiberry set 'ADC Left Input' 'VINL1[SE]'
DEBUG:zynthian_engine_mixer._send_controller_value: amixer -M -c sndrpihifiberry set 'ADC Right Input' 'VINR1[SE]'
INFO:zynthian_gui_admin.stop_rtpmidi: STOPPING RTP-MIDI
INFO:zynthian_gui_admin.stop_qmidinet: STOPPING QMIDINET
INFO:zynthian_gui_admin.stop_touchosc2midi: STOPPING touchosc2midi
INFO:zynthian_gui_admin.stop_aubionotes: STOPPING aubionotes
DEBUG:zynthian_gui_controller.config: ZCTRL 'Main': 0 (0 -> 9), None, None

And the screen is black?