Touch looses calibration [SOLVED]


#1

hi, i put this on “using zynthian” section, because touch hardware works for sure.
I can’t explain when it happened again accross updates, but when i installed a fresh image (the last last one) touch worked well.
after some update, touches got wrong again. I mean for example touching a knob , action happens elsewhere on screen.
In the meantime Is there a way to re-calibrate it? or reset something inside config?.. i don’t know…


#2

There’s some information on calibration here: Integrating custom config files for other Displays (It was “Touchscreen waveshare”) Hope it helps.


#3

Hi… thanks, I didn’t have time to check, but will do soon…


#4

My waveshare32 doesn’t have touch anymore as well


#5

in my case I had to comment (#) the second dtoverlays line in the webconf. Like mentioned in the referenced post.

I committed this change in the repo. Let us know, if this is needed for other displays as well.


#6

ok,tried to recalibrate. replaced calibration.conf content with calibrate output, but nothing changed… Now I’m stuck in another issue: fresh image with last update…


#7

what is your screen?


#8

eh… pitft2.8 …and i know there are some issues on last update… but this happened before omega update too


#9

anyway, by now, after the third attempt on a fresh image and an update, everything turned ok, included touch. but i had to manually pull from github each folder and delete zynthian_envars.sh, which for some reason blocked pulling of zynthian-sys folder…


#10

ok. i found exactly the touch issue: its rotation is wrong. pitft is rotated 90° , but touch ignores this parameter.
example: enabling cursor in webconf, if i touch bottom right corner, cursor stays on upper right corner,
if i move to bottom left, cursor moves bottom right…etc…
all this happens just after some update. starting with fresh image, touch is fine.


#11

you just need to tell us, what the parameters should be for which display (capacitive or resistive) and we can change it.


#12

it’s the pitft 2.8 resistive. i know only this


#13

And the exact values that work for you?


#14

these values should be extracted with calibration procedure mentioned on that post? …


#15

I can offer you that we checkin your values for that screen, that work for you. That’s all.
In the webconf. So that if you change the selection, your values will be used.


#16

yes, it’s ok. but from where (or how) do i extract values?..


#17

Hi @ivanmonterosso!

I’ve fixed the issues with the touchscreen axis rotation in PiTFT 2.8’.
It’s already fixed in the repository and will be included in the new SD image “Omega” for legacy kits v1. It should be out in about 2 hours.

The problem was due to recent changes in X11 that modifies the way input devices must be configured.
I’ve used the “xinput” tool for setting the “Transformation Matrix” in a proper way and ta-chaaan!! It works again! :wink:

Regards,


#18

thanks a lot, man…over last days i did not have so much time, but soon i will try it.


#19

i confirm. it works :slight_smile:


#20

but… at reboot it turns wrong. i have to run manually zynthian_custom_config.sh. is it normal?