Tried upgrading to ORAM release and now Zynthian boots with Control I/O Error

I am using Zynthian on a standalone Raspberry Pi 4. I used the web configuration to upgrade my Zynthian release from Stable to ORAM to use the Korg nanoKontrol2 Midi controller. After completing the upgrade and rebooting my Raspberry Pi, the screen only shows:

IP: (the local IP address) Control I/O
ERROR (red)

I cannot load the web configuration tool by going to the IP address. It looks like my Zynthian installation is completely borked and I’ll have to reimage my SD card. Please let me know if there’s anything I can do to salvage this.


You cannot update from stable to Oram. You must write a new image to uSD. Stable is 32-bit. Oram is 64-bit. We don’t support update between the two.

It’s not even possible to update from stable to ORAM. I’m thinking something else is wrong. Did you to see if everything worked before you did the update? Did you just hit the software update from webcomfig? If you did then that’s not ORAM.

Thanks for the quick response! I will re-image my SD card.


@Hans_JB Using the web configuration tool I just changed all of the repos to point to Oram and then did a software update, not realizing that you cannot update from 32-bit Stable to 64-bit Oram.

@Hans_JB @riban Thanks again for getting back to me quickly earlier. I’ve reimaged my Zynthian SD card and I’m back in business.

In case you were interested in how I was able to “upgrade” to Oram, here’s my steps to reproduce:


  1. Go to the web config (e.g.,
  2. Select Software…Repositories.
  3. Check “Advanced view”.
  4. Uncheck “Stable”.
  5. For each category (e.g., “zynthian-ui”), select “oram”.
  6. Click Save.
  7. Select Software…Update.
1 Like

Happy to see things are back to normal for you.

Great @tkc. Now, have fun with Oram :wink: