Trouble starting pianoteq 6.0 STAGE [SOLVED]


#1

Hello Zynthian community,

I have trouble starting the Pianoteq 6.0 Demo engine.
Iinstalled Zynthian software is as follows:

zyncoder: master (e5859ec)
zynthian-ui: master (aff29cc)
zynthian-sys: master (54a4967)
zynthian-data: master (6712b1c)
zynthian-webconf: master (f9e90de)

All other engines work because the Zynthian symbol in the upper right is animated and the MIDI dialog is shown.
When I choose the Pianoteq engine from the menu and select it, nothing happens…
Your help is highly appreciated.

Thanks in advance, Marius


#2

You need to login via SSH, stop the service and run the zynthian process manually.
You can see the error messages in that case.
If you don’t understand, how to do it, you can find a wiki entry with more details.


#3

Is your software updated to last version?

Thanks,


#4

ui and webconf were…besides the latest checkin from you 13m ago :slight_smile:


#5

Oh, I am sorry I didn’t update zynthian…
I ran several updates via putty and on the zynthian itself.
Now the webconf shows as follows:
zynthian-ui: master (cb5f79b)

Still Pianoteq will not start from the New Synth Layer menu.
If I start ZynAddSubFX XmIng gives me the native GUI on my Win7 PC.

How can I start Pianoteq from ssh shell?
Thanks and God bless, Marius


#6

Hi!
I found the problem. It was introduced yesterday by a last-minute change. Please, update again :wink:


#7

Thank you both @jofemodo and @mheidt for your help!

I thought there was a mistake on my side, maybe a corrupt SD card.
Yesterday I wanted to use my zynthian at a band rehearsal, so I made a system and data backup after the last update.
I wondered why Pianoteq would not start in the evening when it did well in the afternoon…

On my Win7 system I used the following programs:
Xming xming, displays GUI of ZynAddSubFX and Pianoteq engines
PuTTY Windows 64bit

I started Xming first, then I used putty settings found here
Following shell commands came handy:
/zynthian/zynthian-sys/scripts/update_zynthian.sh from here

/sbin/shutdown -r now
was used to reboot zynthian via shell so I had a clean boot process.

Thank you that the solution for this came out so quickly!

God bless, Marius