Unable to find Zynthian for Webconfig [SOLVED]


#21

Good morning to all and happy holidays if you are on vacation …

I have the same problem of accessing the web config because port 80 is NOT open.
With a network scanner I find the zinthian IP address but only port 22 is open where I can regularly access with WinSCP.
But I can not clearly make any web access if port 80 is closed, same thing with zynthian.local as the base is hijacked to the IP address. I performed various tests disconnecting the cable from the GPIO connector and leaving the raspberry 3 connected only to the power supply and to the network cable to the pc.

Some ideas?

Sorry if I have not written correctly, I’m using the google translator.


#22

when you have ssh connection, you can "systemctl stop zynthian-webconf"
then
cd /zynthian/zynthian-webconf/
and finally
./zynthian_webconf.sh

Now you see log messages.


#23

My guess is, that you didn’t update your system.

@jofemodo
where is the diagnosis script? :slight_smile:


#24

Jeje! My guess is that @sevest is using an old SD image. All recent SD images have webconf running in port 80 by default :wink:

@mheidt, the disagnosis script is on the way. Give me some days …

Regards,


#25

I confirm the error. I had downloaded the image of version 2 instead of version 1 …
Now it works properly, thanks.


#26

Somehow it became impossible for me to enter the webconf. It just keeps loading (in safari) and in Firefox it gives me an error saying that it cant connect.
I can still connect via my ftp client and with terminal thou, so there must be some connection. I also tried updating, which changed nothing
Any ideas?

I dont know if the log helps anything, but here it is:

Summary

X.Org X Server 1.18.4
Release Date: 2016-07-19
X Protocol Version 11, Revision 0
Build Operating System: Linux 4.4.26-v7+ armv7l Raspbian
Current Operating System: Linux zynthian 4.9.35-v7+ #1014 SMP Fri Jun 30 14:47:43 BST 2017 armv7l
Kernel command line: 8250.nr_uarts=1 bcm2708_fb.fbwidth=656 bcm2708_fb.fbheight=416 bcm2708_fb.fbswap=1 vc_mem.mem_base=0x3dc00000 vc_mem.mem_size=0x3f000000 dwc_otg.lpm_enable=0 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait
Build Date: 11 November 2016 11:59:59AM
xorg-server 2:1.18.4-2+rpi1 (https://www.debian.org/support)
Current version of pixman: 0.33.3
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (–) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: “/var/log/Xorg.0.log”, Time: Tue Mar 6 16:10:40 2018
(==) Using config directory: “/etc/X11/xorg.conf.d”
(==) Using system config directory “/usr/share/X11/xorg.conf.d”
./zynthian.sh: line 43: /zynthian/zynthian-my-data/midi-profiles/default.sh: No such file or directory
INFO:root:Wiring Layout PROTOTYPE-4
DEBUG:root:ZYNCODER A: [26, 25, 0, 4]
DEBUG:root:ZYNCODER B: [21, 27, 7, 3]
DEBUG:root:SWITCHES layout: [107, 23, 106, 2]
DEBUG:root:DISABLED_MIDI_IN = [’’]
DEBUG:root:ENABLED_MIDI_OUT = [‘MIDI_out’]
Zyncoder: Zynswitches poll thread created successfully
Zyncoder: MIDI tuning frequency set to 440 Hz (8192)
DEBUG:root:IGNORE CH#0 PG#0
DEBUG:root:IGNORE CH#1 PG#0
DEBUG:root:IGNORE CH#2 PG#0
DEBUG:root:IGNORE CH#0 CC#7
DEBUG:root:IGNORE CH#1 CC#7
DEBUG:root:IGNORE CH#2 CC#7
INFO:root:SWITCHES INIT…
INFO:root:SETUP GPIO SWITCH 0 => 107
INFO:root:SETUP GPIO SWITCH 1 => 23
INFO:root:SETUP GPIO SWITCH 2 => 106
INFO:root:SETUP GPIO SWITCH 3 => 2
DEBUG:root:ZCTRL ‘Layer’: 0 (0 -> 2), None, None
DEBUG:root:Snapshot Bank ‘00001-EV’ => MIDI bank 0.
DEBUG:root:ZCTRL ‘Bank’: 0 (0 -> 1), None, None
DEBUG:root:ZCTRL ‘Layer’: 0 (0 -> 2), None, None


#27

Access via ssh.

systemctl stop zynthian-webconf

cd /zynthian/zynthian-webconf

./zynthian-webconf.sh

Now you see error messages, if there are any.


#28

ok thanks!
After doing what you said the terminal showed:

Summary

root@zynthian:/zynthian/zynthian-webconf# ./zynthian_webconf.sh
Traceback (most recent call last):
File “./zynthian_webconf.py”, line 46, in
from lib.upload_handler import UploadHandler
File “/zynthian/zynthian-webconf/lib/upload_handler.py”, line 32, in
import jsonpickle
ImportError: No module named 'jsonpickle’
root@zynthian:/zynthian/zynthian-webconf#

is this jsonpickle something to worry about?

when I open the webconf adress in the browser the terminal doesnt show me new stuff.


#29

I would take a new image and start from scratch.
Or you play with update_zynthian, update_zynthian_data and maybe even update_system

You are not running the latest system.


#30

ok strange i’ve run the update two times from the zynthian. How do I know if I’m on the latest version? Is is written somewhere what the most recent is? Do I always have to update many times to reach the new version?

How does this work, update_zynthian and the others? Tried typing it in terminal but it doesnt understand me ^^


#31

You need to search it
I recommend starting from scratch,


#32

ok I trief the terminal update options you mentioned. Unfortunately didnt help.
I’m going to download the installer and make a fresh sd. I wish I would have constructed my zynthian in a way that makes it easier to reach it ^^


#33

Cut a hole. That’s what the original kit has and what I did with my self made cases as well.


#34

I reinstalled everything now. And run the zynthian_update and zynthian_update_data.sh several times. When I boot I now get the red error message.
I’m also confused that the operation system still seems to be the same like before and you said its not the recent one, right? I updated with the zynthian_gorgona_next_rbpi3_pitft28-2017-11-14 file.

I could load the initial webconf screen though! But its password protected and ‘raspberry’ doesnt work?

In the log it looks very messy now:

Summary

X.Org X Server 1.18.4
Release Date: 2016-07-19
X Protocol Version 11, Revision 0
Build Operating System: Linux 4.4.26-v7+ armv7l Raspbian
Current Operating System: Linux zynthian 4.9.35-v7+ #1014 SMP Fri Jun 30 14:47:43 BST 2017 armv7l
Kernel command line: 8250.nr_uarts=1 bcm2708_fb.fbwidth=656 bcm2708_fb.fbheight=416 bcm2708_fb.fbswap=1 vc_mem.mem_base=0x3dc00000 vc_mem.mem_size=0x3f000000 dwc_otg.lpm_enable=0 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait
Build Date: 11 November 2016 11:59:59AM
xorg-server 2:1.18.4-2+rpi1 (https://www.debian.org/support)
Current version of pixman: 0.33.3
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (–) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: “/var/log/Xorg.0.log”, Time: Tue Nov 14 13:27:01 2017
(==) Using config directory: “/etc/X11/xorg.conf.d”
(==) Using system config directory “/usr/share/X11/xorg.conf.d”
INFO:root:Wiring Layout PROTOTYPE-4
DEBUG:root:ZYNCODER A: [26, 25, 0, 4]
DEBUG:root:ZYNCODER B: [21, 27, 7, 3]
DEBUG:root:SWITCHES layout: [107, 23, 106, 2]
DEBUG:root:DISABLED_MIDI_IN = [’’]
DEBUG:root:ENABLED_MIDI_OUT = [‘MIDI_out’]
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jackdmp 1.9.10
Copyright 2001-2005 Paul Davis and others.
Copyright 2004-2014 Grame.
jackdmp comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
JACK server starting in realtime mode with priority 10
self-connect-mode is “Don’t restrict self connect requests”
control open “hw:0” (No such file or directory)
control open “hw:0” (No such file or directory)
creating alsa driver … hw:0|hw:0|1024|2|48000|0|0|nomon|swmeter|-|32bit
control open “hw:0” (No such file or directory)
ALSA lib pcm_hw.c:1667:(_snd_pcm_hw_open) Invalid value for card
ALSA lib pcm_hw.c:1667:(_snd_pcm_hw_open) Invalid value for card
ALSA: Cannot open PCM device alsa_pcm for playback. Falling back to capture-only mode
JackTemporaryException : now quits…
Cannot initialize driver
JackServer::Open failed with -1
Failed to open server
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started
ERROR:zynautoconnect.zynthian_autoconnect:Failed to connect with Jack Server: Error initializing “Zynthian_autoconnect”: <jack.Status 0x11: failure, server_failed>
ERROR:zynautoconnect.zynthian_autoconnect:ERROR Autoconnecting: ‘NoneType’ object has no attribute ‘get_ports’
Zyncoder: Zynswitches poll thread created successfully
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jackdmp 1.9.10
Copyright 2001-2005 Paul Davis and others.
Copyright 2004-2014 Grame.
jackdmp comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
JACK server starting in realtime mode with priority 10
self-connect-mode is “Don’t restrict self connect requests”
control open “hw:0” (No such file or directory)
control open “hw:0” (No such file or directory)
creating alsa driver … hw:0|hw:0|1024|2|48000|0|0|nomon|swmeter|-|32bit
control open “hw:0” (No such file or directory)
ALSA lib pcm_hw.c:1667:(_snd_pcm_hw_open) Invalid value for card
ALSA lib pcm_hw.c:1667:(_snd_pcm_hw_open) Invalid value for card
ALSA: Cannot open PCM device alsa_pcm for playback. Falling back to capture-only mode
JackTemporaryException : now quits…
Cannot initialize driver
JackServer::Open failed with -1
Failed to open server
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
ERROR:zynautoconnect.zynthian_autoconnect:ERROR Autoconnecting: ‘NoneType’ object has no attribute ‘get_ports’
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel


#35

Are you sure, that your soundcard is ok and configured correctly?


#36

is there a way to configure the soundcard without the webconf?
I don’t know how to find out if its ok. Any hints? I have an audioinjector.
What I can say is that I could still use it normally except for the webconf, but as an instrument, before I put the new image on, so I guess the soundcard is surely not completely broken


#37

show us the logs, when you start webconf manually. Pls search the forum how to do it


#39

cool! Now, after manually opening webconf I could also access it in the browser. Then after beeing able to select my soundcard I’m back on the boat! Next step: rocket science!