Unable to find Zynthian for Webconfig [SOLVED]


Good evening everyone,

Me and a team of 3 others are attempting to build a Zynthian for a class project at UCSD. However, we have run into some issues, mainly that we cannot locate the Zynthian at zynthian.local or its ip address to Webconfig it for our first time boot.

Our setup is 2-in-1 PCB, 2x Dual Controller Modules, RbPi 3, Hifiberry DAC+RCA, this screen from Amazon:

and finally, we hand built the cable to go between screen, pi, and pcbs using @C0d3man’s guide for alternate cabling on the wiki. All wires were checked for continuity with a multimeter.

I think our issue may stem from being on the school internet network as we have tried the following combinations:

Direct ethernet connection between Zynth and Mac
Direct ethernet connection between Zynth and Windows
Direct ethernet connection between Zynth and Virtual Box Linux
Both plugged into room wall router in dorms on Mac
Both plugged into room wall router in dorms on Virtual Box Linux

Any ideas?


Is it possible to log in to your router and check manually what is connected to what


I do not have direct access to the main router as I am on the school network. There is a box in the wall of my dorm with ethernet ports, but I tried connecting the zynthian and my computer to them and they did not see each oher, either by going to zynthian.local or using the terminal commands on the “how to get your zynthian’s IP address” wiki page.


try a port scan in your network.
port 80 it is.


Port 80 should be fine if they can see web pages



somehow I also can’t access the webconf via http://zynthian.local anymore since the last update!
However in Terminal and with my ftp programm I can still access Zynthian. Strange!


Hi @christianforshaw,

On Mini-Maker-Faire Berlin (yesterday) I had also some problems to connect to zynthian.local. But we havn’t tried to locate the problem - to much other things to do :wink:

First of all you should try to check if your Zynthian has got an address with onboard tools:

  • Boot your Zynthian an press “BACK” one time.
  • Select the first entry and take a look at the IP address.

If there is an address like 169.254.x.y your Zynthian doesn’t got an IP address via DHCP. Check if there is an address of you local network. If there so, you should can connect to it via web-browser or ssh.

Regards, Holger


Mines fine dudes :slight_smile:

Guys the up should start like 192.168. ***. ***

Or is some cases it can be 10.10.***.***



@thebez doesn’t have a running zynthian yet.
If you don’t have access to your router, you can get closer by scanning your network (hopefully only 255 addresses - check your subnet) for port 80. Google it how you do this using your operation system.


@ thebez Are these the commands you tried?


You can always plug in a USB keyboard and an HDMI screen (TV) to your Pi so you have a physical console.

give the command (in a terminal):


and look for “inet addr” within all the stuff that spews onto the screen


The display looks very similar to the one I’m using.

Have you tried a very simple setup without encoders, plugging the display directly into the Hifiberry plugged into the RP3? My display is recognized as a Waveshare3.5a and set the wiring to dummies. This test might help in troubleshooting.

Note that the display should be plugged into the Hifiberry so that the body of the display sits above the bodies of the Hifiberry and RP3.


Hi @wolfpaw98, I am a little confused about your note. Do you mean it needs to be directly connected/seated on the Hifiberry? Or is the ribbon cable we built connecting the two ok? The screen just displays white right now.

Also, does this help with finding it at zynthian.local or should the display show something other than white with the direct connection?


Try connecting the screen directly to the Hifiberry just to test out the configuration to see if the screen is working and if you can connect to the Webconfig. I did this to check my Zynthian before I connected my homemade all-in-one board (see latest entries under Success Cases), because I wanted to know if everything was working before I plugged my board in.

With the RP3, HifiBerry and the screen attached directly, you should be able to connect to the Webconfig and get the Zynthian UI. You will need the encoders to control it, but at least with this simple configuration, you will be able to troubleshoot your screen settings using your Webconfig. Once you connect, set the Webconfig to Waveshare3.5a (or maybe it’s Waveshare35a) and set the wiring to dummies. Hope it works for you.


Doing this setup and using “arp -a” in a terminal shows a zynthian.local on ehternet at 169.254.xxx.xxx, but I still cannot load up zynthian.local or that IP address in a browser to access webconfig.


Well, that’s promising. Can you ping the IP address? Unfortunately, I’m not sure that I can help you further than this. I’m not an IT guy.

edit - another thought. Did you solder the 40 pin header to the Hifiberry? Perhaps there’s a problem with a solder joint. Check the connectivity of each pin on both headers on the Hifiberry. Make sure each pair is connected individually and that none are “jumped”.


Pinging it jus resulted in request timeouts, no response :frowning:


Also try the simple setup without the Hifiberry, just the RP3 and the screen. See if you can access Webconf that way. Fingers crossed.


Tried just plugging the Zynthian via HDMI to a monitor. A boot sequence runs, but then it just hangs on a black screen with a _ in the upper left corner forever.


Updated to the most recent image, popped it on a larger Micro SD card, and still didn’t work. But then I tried going to zynthian.local in Safari rather than chrome and it worked fine. Go figure.


oh shit, my IP adress is now -1 | cut -fl -d’ '
It used to have a real one. Can it loose the ip adress with an update??