V3 Kit build - Screen stays blank

Hi everyone. I’m new to the world of Zynthian and received the V3 kit last week. Got around to building it last night. Everything went smoothly and I did not run into any issues building. The wiki is pretty spot on!

Turning it on resulted in a blank screen though. I neither see an error screen nor the actual ui. So I reflashed the SD today. Still the same result.
I was able to connect to the web interface and set the kit to V3. Rebooted. Still nothing on the screen. I activated the UI debug and could not find any error messages. When connecting via HDMI I see loads of green “OK” messages and then it looks frozen prompting a single underscore. I guess that’s when the actual UI activates, but I’m not sure.

Here’s a picture of the build:

Any suggestions as to what I should try next?
Any ideas are appreciated.

Thank you!

When you say nothing on the screen do you mean it shows any sign of life? The most likely cause is a mis plugged lead. It’s quite easy to put an edge connector out by a column or a row so have a very good general sanity check. Disassemble and build again if necessary. I’ve not tried the wonderful new display board, so I’ve not subjected one to the exhausting test cycle and don’t know quite how many ways one can break one :smiley:

When you plug in the HDMI monitor you should be able to see an IP address for the beast as it tries to boot. that will allow you to find out the network location of the zynth. Do you have an Ethernet cable? If you can talk to the machine over any form of network then a little degree of control can be assumed on the box and the process gets a little less agricultural.

Pointing a browser at zynthian.local can be surprisingly illuminating.

The screen is illuminated but simply does not display any content. As I mentioned I was able to connect to the web UI and change the Kit setting to V3 and look at the debug logs. That did not bring me any closer to finding a solution though.

I guess I’ll disconnect and try to reconnect the display when I get home.

Hi @magge!

  • Could you try disconnecting the Zynaptik circuit?
  • Your display seems to be correctly connected right now, but … have you connected the display reversed in any moment?

If you can’t solve the problem, please, send me back the zynscreen+ ribbon bus cable and i will check and send a replacement if needed.

Regards,

Hi @jofemodo,

I removed the ribbon cable and all midi connections from the zynaptik circuit as you suggested while keeping everything else the way it was. Still the same issue. I then removed the ribbon cable entirely and reconnected it on all 3 connectors. Same issue remains.

One thing I noticed though is that the bus cable connection on the zynaptik board is pretty tough. Connecting the HiFi berry and the display is pretty easy going. The connectors slide on and off pretty easily. On the zynaptik you have to force in on and off, but not sure if this has anything to do with it.

I’m pretty sure I have not reversed the connections on either of the bus connectors during this whole process.

Hi!
Same problem here.
I’ve assembled everything carefully so far.
The screen stays white (backlight).
The system boots, Web interface can be called up and settings can be made.

Even if you connect the screen only with the Ribbonkabel on the Pi (without further hardware), the screen remains white.

You could turn the back light on and off to verify it can talk to the zynscreen…

SSH in and try issuing these commands:

Turn off backlight

echo 1 | sudo tee /sys/class/backlight/*/bl_power

Turn on backlight

echo 0 | sudo tee /sys/class/backlight/*/bl_power

Also disconnect the encoders just in case there is a short.

In my case: I can turn the backlight on and off via console.

I have tested the ribboncable for continuity, all pins are ok.

I finally had some time to try the screen backlight controls myself and it’s the same for me. I can turn the backlight on and off without any trouble. So if both of us have the same issue and the raspberry can control the backlight of the screen, then it can’t be the bus cable right? So where do we go from here? There must be some other way to figure out what’s causing this issue. Any further ideas?

Thanks.

Hi @zynthianers!

Excuse the delay in my answer. I’m on vacances in a little country house in the south of Catalunya, trying to “disconnect” a little bit …

Those of you having problems with the Zynscreen, plase, send me back the screens, including the ribbon bus cable. As soon as i come back to BCN (a week), i will check the “broken” displays and send replacements. Sorry for the inconveniences …

BTW, could you send me a “closed” photo of your zynscreen backside?

Thanks!

Hi @jofemodo,

I attached a photo of the back of my screen with all cables detached:

Maybe you can see something. I don’t see any obvious issues, but I also have no clue :smile:. If you can’t see any issues I will try to send the screen + bus cable back to you within the next week.

Best regards,
Markus

Hi Markus!

I don’t see anything strange. Please, send me the display + ribbon bus cable and i will send you a replacement ASAP.

Thanks!

My address:

Fernando Moyano - MADE Makerspace
C/ Noguera Pallaresa 59-61
08014 - Barcelona
SPAIN