V4.5 Kit Problems with two rotary encoders on the right

Hi everyone - yesterday I completed my V4.5 Kit build with the ZynScreen v1.5and for some odd reason CTRL-4 and CTRL-3 learnshot/select don’t work at all?
I swapped the rotary encoders for a test - the encoders themselves seem to work fine because i can use them to adjust audio levels as a test case when cross-swapped.
Is my ZynScreen DOA? Am I Missing a jumper?

Thanks & Regards,


1 Like

Hi @blackcoffeerider welcome.

check on Zynscreen if pins of encoders connectors are not bended.

Checked - straight as an Arrow. Connectors slide in with a slight resistance as it should be.

It really smells like a bad/missing/misplaced jumper.
Do you have the 2 jumpers placed as shown in the wiki photo?

Also check that jumpers are making good contact, etc.

If this is not the problem, please, check if you can see some “solder bridge” in the MCP23017 chip. It’s the big one placed in the middle.


@le51 & @jofemodo
ty both for the ideas!
Jumpers are OK. I checked with a multimeter what is connecting to what and found no shorts. I am not sure if i read the schematics on github correctly - my electronics engineering classes are almost 20 years in the past - but the “beep” test made me think everything is ok on that end…
Any way to check the cable without replacing it completely? I noticed that on the “Main Daughter Board” there are also Ctrl-1 to Ctrl-4. Are these for the same purpose?
One thing that struck me though looking ath the picture the colour codings on the cables are the same on the refrence picture in the wiki from top to bottom - i have them inverted from left to right? The Plugs are “poka yoke” (QA speak for “fits one way only”) so i am sure that they are seated as designed. Have the sockets been flipped in a later design?

I just tried to connect the to controls on the right (when looking assembled from top) to CTRL 3 & 4 on the “main daugther board”. Cables luckily are long enough but same issue. Could this now be related to a jumper switching issue - sorry for fishing in the dark here :grimacing:?

The zynaptik v3 that you have can be used for connecting the encoders instead of the Zynscreen. It’s not so comfortable at a wiring level and it’s not currently supported by the stable image, but it works perfectly in the testing branch. For getting this working you have to access the webconf and change to the testing branch. Then configure the wiring layout as “MCP23017 Zynaptik v3”. For doing so, first you have to select the kit as “custom”. This is not the easiest way for a beginner, but it depends a lot of your skills and patient.

I hope the new layout configurations will be available on stable very soon, but i couldn’t say a date.

If you don’t like this solution, i would send you a replacement for the Zynscreen, as it seems to have some problem with GPIO’s bank B. It could be a broken chip or some bad soldering.


BTW, have you tried to swap the cables or only the encoders?


I swapped the encoders leaving them on the same cable only switching the socket on the displays board so far (out of pure lazyness since it is less fiddly to do it there than at the encoders end). Thus i doubt it to be a cable problem.

I will try patching the wires to the zynaptik v3 directly and switch to testing branch if i manage to get the cables there - they seem a bit short but maybe with luck and dedication.
That way we can rule out for sure if there is something wrong with the encoders that i didnt catch for some reason.

Hope to get to this this evening - will report back if i have any news.

Success - partially at least.
It was a bit fiddly as expected

It is key to hold everything at an angle and to leave the encoders PCB not straigt but at an angle to give the cables some slack.
Start with the Encoders - then connect the display cable :grimacing:
But the encoder nobs work!

Not sure if i am missing something but should the S1-S4 buttons have a preset function though?
I thought they were switching layers?

Anyway - gave the thing a spin and i am realy impressed with the DAC Quality - have seen/heard a lot less for way higher price!

Got carried away while writing this playing around with it :S

1 Like

So you managed to update to “testing” branch and knobs are working. Well done!!

The bad news is that the display switch buttons are not going to work with this config. I will send you a working display ASAP, OK? You deserve what you payed for :wink:

Nice to hear this! The ZynADAC is a good piece of hardware! I must say, to be fair, it’s very inspired by HifiBerry designs :innocent: