V5 Questions, Glitches and Suggestions

I received and assembled my V5 last week and have some questions and thoughts.

Regarding Midi recorder - Is there a resolution value adjustment? I am free recording from my electronic drum module into the V5 and when I play back the Midi recording to my module -

A. Playback seems quantized and not playing back as was recorded.
B. Does not play the same notes back into my module.
C. Would be very helpful to have a screen to see what notes were recorded into the V5 and be able to scroll through the track and edit the Midi notes. Is this in the works?
D. Have the ability to edit the recorded midi track and import into a pattern in a scene.

Metronome - plays only when transport is playing or recording. Would be great to have the option of having it play all the time. Also suggest having a quicker option to turn metronome on and off using the metronome button - quick press on/off and longer press as the edit function.

Midi Step Mode Screen - suggest a rotary to zoom in and out for easier editing especially when doing many beats per pattern.

Scenes - Pattern Editor Menu - If I change any of the Beats/bar, Beats/pattern and Steps/beat - it changes for all the patterns in the scene. Am I not able to have let’s say 7/4 time for one pattern and 4/4 for a different pattern in the same scene?

While in scene screen the play transport button plays either an audio file or midi file unrelated to the scene. Is this correct?

Generator Chain - Click BPM - when changing tempo goes 63.0 to 64.2 to 65.4 etc. - this resolution needs to be corrected.

If I create a new Midi chain - Arpeggiator - Bypass is automatically ON but still activates my midi device. If you turn this off and the arpeggiator is running, then you can never turn the arp off - gets stuck on. have to remove from chain to stop arp.

Audio Player - suggest a zoom to cursor - instead it just zooms to area nowhere near cursor. Scrolling is with touch screen but can get very tedious with large files. Will crop function be expanded? To crop to new audio file? Right now, not sure what the function of it is as it acts same as loop.

I see now that the touch screen can adjust the waveform amp zoom and zoom range which is great. Placing markers - very difficult to use with fingers on touch screen as marker placement. It’s the only way I could achieve it. Drop marker at cursor location would be an easier option.

1 Like

Hi @Octiv8 !

Welcome to zynthianland! And thanks for your detailed report!

I hope you are enjoying zynthian although it’s far from perfect. As you probably have noted, zynthian have many legs and offers a nice amount of functionality, not always free of issues, that we are always fixing too :wink: And not simply “fixing” bugs. Zynthian software is in constant evolution driven by user’s feedback, so your feedback is really important.

First of all, you have to understand that we are only responsible of a little part of the software zynthian runs. Zynthian include hundreds (thousands?) of plugins and synth engines that we don’t develop. By default, only a small part is enabled and we try to keep this list curated and free from issues, but of course, issues always find the way.

Regarding your comments, i will answer between lines:

MIDI recorder should record MIDI without quantization. Perhaps @riban could tell something about it.

The resolution should be in the range of the internal latency, that is around 12ms by default. You could reduce the internal latency if you need better resolution.

Could you elaborate a little bit more? What is playing then? How the notes are different? Is changing the note values? Velocities? Adding other messages, like pitchbend?

This is the the roadmap. Indeed, importing mid files from pattern editor is working right now.

If you want to test latest improvements and fixes, you should consider changing to testing branch. It’s quite stable in the latest weeks and include a bunch of new features, like improved launchpad & Akai MIDImix support, per-device MIDI routing, pattern editor workflow fixes, etc.

Currently, short-pressing the metronome button is tap-tempo. If we make the change you propose, someone is going to complaint because he wants the tap-tempo quickly accessible.
I don’t say no. I say, let’s talk about it. Let’s talk about use-cases and find the best solution.

Of course. It’s on the roadmap with very high priority. Pattern editor screen needs improvement in many aspects.

Yes, you are right. But i think it’s not a core limitation and perhaps it could be improved easily. @riban, could you say something on this limitation? Can we have patterns with different “time footprint” in the same group? I though yes, but i found this limitation a few days ago too.

Well, it’s not really unrelated, but it could seem unrelated. It depends of your POV.
Audio recorder is available from most of screens, so you can always start an audio recording from anywhere. By coherence, we decided to keep the audio player functionality when audio recording is available. So, for instance, in the “scene” screen (zynpad), you can start an audio recording and also replay the latest recorded audio track.

I’m not totally satisfied with this and i would like to improve, but it’s not so easy.
For instance, in the “scene” screen, i would expect to launch a sequence when pushing “play”, but then, it feels “incoherent” to start an audio recording by pressing “record”. Moreover, pushing play to play a sequence is suboptimal and redundant as you would do it better with the 4th rotary or the touch. Having this into account, it seems “fair” to don’t waste a button and keep “audio play” functionality, although it feels strange, i know.

Anyway, i’m open to improve this. Make your proposal! :wink:

It seems a problem with a plugin’s parameter. I would take a look …

I also had some bizarre behaviour from the Arpeggiator plugin in the past. We should contact the plugin’s author to see if this can be solved. Or perhaps someone could take a look to the code and fix it? Until then, having some care when using it is the best “solution” we have.

Regarding the audio player, it’s one of the last additions and it’s being improved very fast by Mr. @riban. And yes, we have lot of plans for it.

Best Regards


Thank you for the detailed information. Forgive me as I’m new to this open source environment and I’m understanding now more clearly how this works. It’s a bit of a learning curve for me but I’ll get there. I appreciate your help. Thx

1 Like

Indeed the MIDI recorder should record exactly what you play. If you are getting recordings with the wrong data then please report in the issue tracker with detail of the workflow and example result. I am not aware of such an issue. The resolution is 96 ticks per quarter note. (This could be improved in future revisions but was acceptable as a replacement for the previous implementation.) Playback of existing SMF will use the ticks per quarter note (or timecode based resolution) encoded in the SMF file. This is then word clock locked to audio. There should not be any beat based quantisation. You should get what you played within the constraints of the record resolution. Of course this then is influenced by the timebase of the Zynthian which is set by the tempo control (and maybe the sequencer’s timebase configs).

I too realised recently that there is a constraint on the timebase within patterns that did not support different beats per bar. It is actually worse than you say. It is global, not per scene. This is definitely something that I want to resolve because it blocks my own workflow. (4/4 songs are very nice but it isn’t the prog rock that I like to play!!!)

That was (kinda) implemented (it depends upon what you mean by “cursor”) but changed because I felt it was less beneficial. Zoom used to keep the current play position in view but now it zooms on the current centre, i.e. it avoids moving the view (except when zoom results in hitting the start or end of the audio). This feels more intuitive / useful, i.e. you position where you want to view then zoom on that point. Adjusting the markers brings them into view, initially positioning them towards the side of the view that best suits them, e.g. loop start would appear towards the left side whilst loop end would appear towards the right side. During playback the play cursor is kept in view.

There is a region at the bottom of the screen that acts as a scroll bar. Dragging within this region will allow fast scrolling in large files.

No! Crop sets the in and out markers. Only audio within that region is available to be played. It is like cutting off the start and end of the file. Loop sets markers for looping the audio, e.g. when playing from a MIDI keyboard the file will start playing from the in-crop marker, play until the end-loop marker, loop between the loop markers whilst the key is pressed then when released it will play to the crop-end marker (or earlier if the release time of the ADSR envelope is shorter). The reason the loop and crop may initially appear similar is because you can’t have a loop outside the cropped region so adjusting the crop markers can push the loop markers but they are independant values.

We could do with documenting this but as @jofemodo mentioned, some of this functionality is fairly new - but my bad for not adding to wiki. (Now where did I put that 25th hour? Ah yes! It happened last Sunday. :wink: )


Thank you for the info and clarification. So happened that my Pi got fried somehow. Replaced with another and up and running again.

It would be great to have the option of running the metronome continually if possible.

How do I update to the testing branch versions?

The midi issue may have to do with my drum module 2box Drumit 5 - could be the high hat continuous controller changing something. Tested without using it and seems to replicate my playing properly.

Is there a midi note log within the Z? Like the one under webconfig - interface - midi log. That would be helpful.

OK, forgive me but I don’t know if Z is working correctly at this point. Using the original OS. I am no longer able to record audio through the inputs. Had no issues recording previously. Tried different sound sources etc.

When I play an audio file that I have previously recorded and I am in the waveform screen, when I semi long press SEL/Yes (to delete or mark as favorite for example) The Z goes to Chain Options screen with nothing below the heading. When I press another button it freezes. Waveform symbol moves but nothing can be done.

Is this a known glitch or just my unit?

Ok just checked this with the latest Testing Branch OS and the same Issues as above - not recording audio and freezes.

Is it my specific unit?

So, before I make any more suggestions or glitch reports and embarrass myself I need to figure this out.

Any suggestions?

Hi @Octiv8 !

It seems you are using the “global” audio player and not an audio player that you added into a chain.
This is an issue on stable & testing. I will solve it ASAP. Thanks!

BTW, for deleting or marking as favorite a recording you have to do it from the recording list, not the waveform screen.

This is not related. You should be able to record from the audio inputs. Have you checked the audio input gain/level in the audio levels screen? Check also that the “Input Mode” is right.

BTW, if you are using a single SD-card and changing from stable to testing and back, strange things could happen, like audio level configuration being lost or worst. It’s for that we strongly recommend having dedicated SD-cards for stable and testing.

All the best,

1 Like

Indeed, i just pushed a fix to testing branch. You can update and test.


1 Like

I do have separate SD cards for each OS. Yes, when I would previously hold the SEL/Yes in waveform screen it would take me to a screen with the Preset : Name of File and below list to add as favorite, rename , delete. It is intermittent though and does work but when starts glitching then keeps glitching. Is the update still the 2311 labeled as the previous under TEST folder?

I will test the audio recording by adding an audio chain.

1 Like

You must update your testing SD card from the webconf.


Ok, I was able to get the audio working by loading the sooper looper. Did get audio play through monitoring and then was able to record again using the “Global Audio Recorder” . Still need audio through monitoring for the global recorder. Or make a plain audio chain recorder. Unless there’s a plugin I’m not aware of for multi-track recording.

A big ask is to have the ability, for both midi and audio, to start recording on first midi note received or audio received. When I used the sooper looper I have to press record ( with no metronome by the way ) and then start playing. When I’m finished and it loops my recording there is always a space of silence from the delay between hitting record and playing. And I don’t see where I can edit my loop to correct that in sooper looper. This would also save time with the global recorder. Audio I can edit the loop in audio editor but for midi there is no midi editor.

Having the metronome be able to play continuously regardless of play or record mode is essential.

Very interesting area of investigation.

Hi @Octiv8! It’s a bit confusing what you are doing because you mention Sooperlooper, audio recorder and MIDI recorder which are three distinctly separate things.

It is possible to set Sooperlooper to start recording when an audio threshold is exceeded. @Baggypants did a video demo on this recently.

MIDI recorder only starts recording from it’s first received MIDI command which is what I think you want.

Audio recorder does not currently have a threshold record implemented. We could possibly add it is a feature request is added to the issue tracker.

The first loop created in Sooperlooper defines the loop length. This is normally then fixed. It can be “multiplied” and your can also “insert” recording but neither is the editing you desire.

Audio player does allow the start and end to be changed to adjust the duration of a recording and also the loop can be set to and time within these start/end markers.

1 Like

I’m getting an upside down screen and Zynthian ERROR IP: Exit:1

Do I have to reflash SD?