VNC not accessable on 2024-05-22-zynthianos-bookworm-aarch64-oram-2405.img

Used test image 2024-05-22-zynthianos-bookworm-aarch64-oram-2405.img copied it on SD card.
System is:

Raspberry Pi 4 Model B Rev 1.2
Audio: HifiBerry DAC+ ADC PRO
Display: ZynScreen 3.5 (v1)
Wiring: MCP23017_ZynScreen
I2C: MCP23017@0x20
Profile: v4_stage

zyncoder: oram (84612a6)
zynthian-ui: oram (19ac17d)
zynthian-sys: oram (7a6c26f)
zynthian-data: oram (db0355a)
zynthian-webconf: oram (5f6f937)

  • Starting up zynthian → working nearly as expected.
  • Wifi-connection was established → webconf access fine.
  • VNC server set to “ON” and saved → no entry in the in the webconf sub-menu entries of “interface” and to the vnc.html page on port 6081/6080
  • console with ssh connection shows vnc server running, but terminal in webconf doesn’t (ps xau | grep vnc)

Now I updated to

zyncoder: oram (b5c87b7)
zynthian-ui: oram (6216708)
zynthian-sys: oram (d542728)
zynthian-data: oram (db0355a)
zynthian-webconf: oram (c27fea2)

  • VNC server still ON, but not in the interface sub menu, restarting does not help, allthough on ssh console it is running - it does show nothing on the terminal via the webconf.
1 Like

I just tested and it worked for me.
Did you reload webconf dashbord after enabling VNC? Did you try accessing the VNC URLs directly:


1 Like

which browser and host are you on?

@wyleu firefox, chromium and chrome to be sure. But with all of them it worked beforehand.
@jofemodo , tried all this, cleaned any caches, tried direct address… but no access.

Short version: If I “burn” the older image 2024-03-01-zynthianos-bookworm-aarch64-oram-2403.img on SD card, the VNC server is accessible and the entry in the dashboard’s submenu.
If I use the newer 2024-05-22-zynthianos-bookworm-aarch64-oram-2405.img, it is not!

Longer version:

I am momentarily burning the SD card the 3rd time (2024-05-22-zynthianos-bookworm-aarch64-oram-2405.img) and starting from scratch. This time I’m using LAN not WiFi.
I restarted the router, the desktop and zynthian.

Set VNC to ON, it shows “ON” on the dashboard page of webconf, but no entry in webconf menu.

While logged into zynthian:

ps xau | grep vnc

results in …

root 1676 0.0 0.3 19040 11796 ? Ss 19:34 0:00 /usr/bin/perl /usr/bin/vncserver -localhost no -rfbauth /root/.vnc/passwd :1
root 1677 0.0 2.0 241232 77904 ? Ss 19:34 0:00 /usr/bin/Xtigervnc :1 -localhost=0 -desktop zynthian:1 (root) -rfbport 5901 -PasswordFile /tmp/tigervnc._ifQlk/passwd -SecurityTypes VncAuth,TLSVnc -auth /root/.Xauthority -geometry 1920x1200 -depth 24
root 1678 0.0 0.0 2320 1280 ? Ss 19:34 0:00 /bin/sh /etc/X11/Xtigervnc-session
root 1684 0.0 0.1 7876 3968 ? S 19:34 0:00 tigervncconfig -iconic
root 2154 0.0 0.1 29660 6080 ? Ss 19:34 0:00 /usr/bin/x11vnc -forever -bg -rfbport 5900 --rfbauth /root/.vnc/passwd -shared -o /var/log/x11vnc.log

Now I was installing the older image (2024-03-01-zynthianos-bookworm-aarch64-oram-2403.img):

Same process, but this time, when I was switching VNC to “ON” the sub menu entry appears in the dashboard view of zynthian’s webconf.

Logging into zynthian and …

ps xau | grep vnc

results in …

root 1780 0.0 0.1 29492 5824 ? Ss 20:11 0:00 /usr/bin/x11vnc -forever -bg -rfbport 5900 --rfbauth /root/.vnc/passwd -shared -o /var/log/x11vnc.log
root 1781 0.0 0.0 6932 3244 ? Ss 20:11 0:00 bash /zynthian/zynthian-sw/noVNC/utils/novnc_proxy --vnc localhost:5900 --listen 6080
root 1803 0.0 0.3 19020 11864 ? Ss 20:11 0:00 /usr/bin/perl /usr/bin/vncserver -localhost no -rfbauth /root/.vnc/passwd :1
root 1804 0.2 1.9 241324 77520 ? Ss 20:11 0:00 /usr/bin/Xtigervnc :1 -localhost=0 -desktop zynthian:1 (root) -rfbport 5901 -PasswordFile /tmp/tigervnc.24TW03/passwd -SecurityTypes VncAuth,TLSVnc -auth /root/.Xauthority -geometry 1920x1200 -depth 24
root 1805 0.0 0.0 2320 820 ? Ss 20:11 0:00 /bin/sh /etc/X11/Xtigervnc-session
root 1811 0.0 0.1 7876 4000 ? S 20:11 0:00 tigervncconfig -iconic
root 1955 0.0 0.0 6932 3236 ? Ss 20:11 0:00 bash /zynthian/zynthian-sw/noVNC/utils/novnc_proxy --vnc localhost:5901 --listen 6081
root 2347 0.0 0.0 6092 1920 pts/0 S+ 20:13 0:00 grep vnc

see the two extra lines of novnc_proxy calls??
Obviously with the newer image, freshly used, the novnc_proxy script is not called, I check it later when going back to the newer image download again.
Now I am upgrading to see the difference.

I’ll write another post on the result of the update process.

Updating from 2024-03-01-zynthianos-bookworm-aarch64-oram-2403.img was no success - ends in permanent error screen.

Back again to 2024-05-22-zynthianos-bookworm-aarch64-oram-2405.img: fresh SD card installation, booting zynthian, switching VNC “ON” → no submenu entry…

… logged into zynthian

obviously the novnc_proxy was not running!

Also the script for starting novnc_proxy wasn’t installed.

I called


switched the VNC “ON” … and guess what: the entry in the webconf menu was visible, and vnc could be called.

The question for me is now:

  1. Must I call other install scripts, or
  2. shouldn’t they be called automagically while booting.

If 1: which one’s
if 2: why are they not called

Finally: should I write a bug report?


I changed the Subject a little bit… I know, this is no good style.

Now I updated via webconf, and with, rebooted and got an error:

obviously the webconf failed to start:

systemctl status zynthian-webconf.service
● zynthian-webconf.service - Zynthian Webconf
Loaded: loaded (/etc/systemd/system/zynthian-webconf.service; enabled; preset: enabled)
Active: activating (auto-restart) (Result: exit-code) since Tue 2024-06-04 22:25:32 BST; 31ms ago
Process: 1811 ExecStart=/zynthian/zynthian-webconf/ (code=exited, status=1/FAILURE)

I was following the error and found that the module “vcgencmd” was not installed in the python virtual environment, installed it, and the error was gone.

Hence the image doesn’t contain the module in the /zynthian/venv/ folder structure… bug?

There seem to be some other issues, I give up. Too late now.

I can confirm that I can’t get the VNC submenus to show up either when VNC is enabled (oram 240522, also after running software upgrade).

I noticed this a few days ago and created a ticket for it: Bug: Unable to enable VNC in latest oram (240522) · Issue #1052 · zynthian/zynthian-issue-tracking · GitHub .

Normally I use Firefox, which has worked fine before. Haven’t tested with any other browser.

It works for me. Both UI and engine views

zyncoder: oram (a7976d8)
zynthian-ui: oram (199670b)
zynthian-sys: oram (d542728)
zynthian-data: oram (db0355a)
zynthian-webconf: oram (c27fea2)

@le51, did you start from scratch with oram 240522? Or is it an updated system from an earlier image? Mine was also working until I used the newer image.

yes I did. And I’ve done a system updates each time I started my Zynthians. I hadn’t tried VNC before today, but so far, this morning, everything was working Ok.

Ok, perhaps the fix to delete the unnecessary module import in

did the trick. This was causing starting issues obviously.

Fingers crossed.

Cheers @jofemodo and thanks @le51