Waveshare 10.4" touch screen issues

New to zynthian, just getting started building a synth. I started with 64bit bookworm yesterday pi4/8 and created a sd for zynthian today.
My waveshare 10.4 cap touch booted perfectly with latest download.
Trying to navigate the back arrow worked in the upper left but nothing else did.
I pulled the conf file on the bookworm sd for the HDMI settings and copied into /boot/config.txt the HDMI settings I got from waveshare

hdmi_timings=1600 0 80 32 112 720 0 30 3 33 0 0 0 60 0 87000000 0

Rebooted and used a keyboard to get to calibrat the touch screen.
I can’t get to the third point of calibrate.
Center, upper left fine then lower right nothing no response any where on the screen.
Site addres for info

My eyes aren’t so great a bigger screen allows me to reed the text.
Any ideas on a fix would be appreciated.

1 Like

Welcome to Zynthian. I don’t have any experience with Waveshare but I have gotten several different screens working with Zynthian.

Does the Waveshare work with standard RPi OS? If you haven’t tried that, I think it would be a good first step.

When you say:

I’m not sure what you mean - could you clarify whether you are trying Zynthian Bookworm test version or ? If so, could you try the latest regular 32 bit Zynthian?

I could not easily find the Linux calibration doc in https://www.waveshare.com/wiki/10.4HP-CAPQLED - are you saying the first two steps worked? Could you point to the instructions you’re following?

There is no Zynthian Bookworm yet. We are still working on it. You must currently start with Zynthian Stable image and switch to testing branch if you feel brave.

The screen calibration is of most benefit for resistive touchscreens like those used on older Zynthians (V4 and earlier). Capacative touch screens are generaly well calibrated but sometimes need some hints (config) to set rotation / mirroring.

1 Like

Thanks for the correction @riban - the 64bit test version I was thinking of was this one:

Which of course is not bookworm at all, but bullseye.

I installed raspberry pi os 64 bit version on an SD and got it running with the touch screen at first boot without any problems.
The os had issues. Could run ardour and connect to my USB 2channel input but could not get jack happy could not get the Akai play to go . Zynaddsub jack issues just a real pain. Figured I’d get back to it later and pulled the latest for zynthian.

Is there a file I can .bak, and dink with to try expanding the area the touch cal sees?
May or may not be related but no mouse on screen but mouse scroll button works
its a USB as well. Haven’t tried the Akai play yet.

this is the /etc/X11/xorg.conf/99-v3d.conf on the raspos
Section "OutputClass" Identifier "vc4" MatchDriver "vc4" Driver "modesetting" Option "PrimaryGPU" "true" EndSection
there is nothing in it or the boot config.txt for inputs.
im typing this in on the touch screen keyboard on the pi now.
cross checking config files with the zynthian sd in a usb adapter. ive found
from a link,
Section "InputClass" Identifier "libinput touchscreen catchall" MatchIsTouchscreen "on" MatchDevicePath "/dev/input/event*" Driver "libinput" Option "CalibrationMatrix" "-1 0 1 0 -1 1 0 0 1 EndSection
its similar to the x11 conf in zynth. but it calls for calibration instead of transformation.
but no /dev/event in zynth.
rootfs/home/pi/config/touchscreen in zynth
has 2 files
Goodix Capacitive TouchScreen.
ADS7846 Touchscreen.
lsusb lists this device as
Bus 001 Device 003: ID 0712:000a Waveshare Waveshare.
iv checked the zynthian git and waveshare was deleted.
is there an issue associated with waveshare?
should i create a config file with Waveshare Waveshare as matchproduct in the touch screen dir or mod the 99-config
im not sure how zynth looks for devices.