Webconf tool update!


#1

Hi @Zynthianers!

The webconf tool has been updated. Big Thanks to Markus Heidt (@mheidt) who is working hard to improve the tool.

  • New => The tool is getting bigger, so we have organized the menu in 2 levels.
  • Fixed => “Reboot” option
  • New => Audio Mixer Master volume
  • Improved => WIFI config

Some features are not implemented in the “core” yet. You can configure it, but not use it :roll_eyes:

  • Library => Snapshots
  • MIDI configuration => Master MIDI channel, etc.

The full list of fixes and improvements is long, but you can check the changelog in github:

Enjoy!


#2

Hello @jofemodo and @mheidt !

This are great news. I realy like the webconf!

Regards,
Martin


#3

Hi guys!

After the update i’m getting the following error:

Any tips?

Regards, Rod.


#4

Hi Rod,

I can’t test the latest master branch for the next 3 weeks.
But if you would stop the service and run the webconf shell manually, you would see the log message.
Maybe there is a workaround until I checked it myself.

Kind regards
Markus


#5

Rod, which soundcard are you using?

Could you post the results of
amixer scontrols


#6

Sorry for the delay, Markus.

This month i will be on business trips all the time. As soon as i can call my Zynthian home i’ll send more details.

I’m using an AudioInjector.

Regards, Rod.


#7

Hi @mheidt

I started webconfig manually and only had the following error:

amixer: Mixer attach default error: No such file or directory

But, after setting up zynthian and rebooting, it worked fine!

Regards, Rod


#8

You don’t get the 500 either?


#9

And please check how many volume sliders you have. We can filter them when we know which.


#10

I fixed the problem 2 days ago, but i forgot to notify: :blush:

Regards!


#11

Hi ynthianers!

I’m having a little problem with the ALSAMixer settings with Webconf.

Every time I change some ASLAMixer parameter through Webconfig and restart Zynthian, the option “Output Mixer Line Bypess” returns on.

Is it possible to enable this option in Webconfig?

PS.: I’m using an AudioInjector Souncard

Regards, Rod


#12

Actually I provided a mechanism that allows to disable unused controls.
Especially those boolean ones.
i can offer that only “Master” and “Capture” is shown in the webconf.
Would that help?

That’s how i did it with the soundcards I know.


#13

Hi @rod_amaral!

Normally AlsaMixer saves the changes you make and restore it at startup.
Can you verify that this save/restore feature is working for other controls?

Regards,


#14

Hi Guys!

I’m on a work trip this week, I’ll check the settings as soon as possible!

Regards, Rod