Webconf tool


#1

It’s me again with more questions than answers I’m afraid. As mentioned in my question about bluetooth speakers I don’t seem to be able to connect to the webconf tool.

I’ve started again with a pretty standard gorgona image. The only thing I’ve done to it is connect to wifi. So I can then get the ip address from the zynthian and ssh on to it with no problems. If I try to get to the webconf tool with http://999.999.999.999 from the machine I can ssh from, (using firefox) I get an ‘unable to connect’ error.

If, as jofemodo says, the webconf tool starts automatically I think there’s only a couple of possibilities. Maybe there is a firewall getting in the way somewhere. That seems pretty unlikely since I don’t think I’ve added anything in that area. The other possibility is that the webconf web server is failing with some sort of error. Is there any logging where I can look for evidence of this? Any other ideas?


#2

Hi @oily_wagg!

999.999.999.999 is not a valid IP and it’s not possible that your Zynthian (or any other device in the world) have this IP :wink:

I recommend you to connect with ethernet and get the IP from the boot log. You are using a HDMI display, true?

Regards


#3

No, I mean I was using the ip address that the zynthian ui gives me. Not really all those 9’s. I’ve also tried a direct connection with an ethernet cable still using the ip address that the zynthian ui gives me and that didnt work either.

What do you mean by boot log? Does that mean I can’t rely on the ip address that you can get from the ui?

What HDMI display do you mean? The zynthian has the standard PiTFT.


#4

OK! Sorry. I was confused with so many threads in the forum … jajaja!

Of course, you can rely in the pi address given by the UI, but depending on your software version, it can give you several IPs and you have to choose the right one. Please, can you specify the IP it gives you?

Anyway, if you use Ubuntu in your PC, the “link local” feature should work and you could use “zynthian.local”.

Regards,


#5

The UI is currently giving me 192.168.1.106. That’s with the wifi connection. Before I added the wifi and was trying to use a direct ethernet connection it was 192.168.1.99. Not sure why you’re interested in the actual address though.

zynthian.local gives me the same unable to connect error. But pinging zynthian.local does resolve to 192.168.1.106


#6

The IP seems good. It’s not a 127.0.0.1 or something like that. As i tell you, some versions of zynthian software give several IP address, and some people doesn’t know the difference. But you’re doing right …

The only answer i can give you is that:

It seems that you are using an old SD image. If you were using one of the last, it would work out-the-box. Please download and burn one of the last SD images.

Sorry if i’m wrong … but it’s the only explanation i have :wink:

Can you send the output of this command in your zynthian?

pstree

Regards,


#7

OK. I’ll give that a go. It isn’t an extremely recent one but I don’t think it’s more than a month or so old.

Anyway


#8

oh dear. My image is dated back in december last year. Sorry.


#9

OK! I’m happy of giving a good diagnostic :wink:
Tell me where did you get the link and i will put a note or remove the link to avoid future misunderstandings :ok_hand:

Regards,


#10

It’s the image from the christmas newsletter last year. rbpi3.

There only seem to be two later images available. Next from the 14/11 this year and edge 18/9. I’ve tried both now and I do get the web conf tool with both of them. What I don’t get with either of them is wifi. After configuring there’s no connection. No wlan0 device at all.


#11

Try restarting your zynthian. It should start your wlan0 interface.
How is your case? If it’s metalic, you would have problems for getting a decent signal level inside …

Regards,


#12

I’ve lost count of the number of times I’ve restarted with different images. The case is one of your wooden laser cut boxes. Like I say I had wifi working fine with the december 2016 image but not with either of the two later images.

Going a bit deeper with the 14/11/17 image it seems there is some renaming of wlan0 going on. /etc/udev/rules.d/70-persistent-net.rules contains

 This file was automatically generated by the /lib/udev/write_net_rules
# program, run by the persistent-net-generator.rules rules file.
#
# You can modify it, as long as you keep each rule on a single
# line, and change only the value of the NAME= key.

# USB device 0x:0x (smsc95xx)
#SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="b8:27:eb:6d:90:7e", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"

# Unknown net device (/devices/platform/soc/3f300000.mmc/mmc_host/mmc1/mmc1:0001/mmc1:0001:1/net/wlan0) (brcmfmac)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="b8:27:eb:38:c5:2b", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="wlan*", NAME="wlan0"

# USB device 0x:0x (smsc95xx)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="b8:27:eb:af:02:be", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth1"

# Unknown net device (/devices/platform/soc/3f300000.mmc/mmc_host/mmc1/mmc1:0001/mmc1:0001:1/net/wlan0) (brcmfmac)
#SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="b8:27:eb:fa:57:eb", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="wlan*", NAME="wlan1"

# Unknown net device (/devices/platform/soc/3f300000.mmc/mmc_host/mmc1/mmc1:0001/mmc1:0001:1/net/wlan0) (brcmfmac)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="b8:27:eb:fa:57:eb", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="wlan*", NAME="wlan1"

I’ve tried commenting out the references to wlan but it’s re-generated by a reboot and I haven’t worked out how to change what’s generated.

I don’t have anything plugged in to the usb slots no wifi dongle or anything like that.