Webconfig Soundcard config is not recognised by system


#1

Hi,
i am trying zynthian with only a raspi 3. i got a monitor with hdmi running. I set the knobs to Dummy. i connected a usb Soundcard which i configured in the webinterface.

But the splash screen shows a red error.
So i loged on with ssh, stopped the service and startet the ui manually with
/zynthian/zynthian-sys/sbin/zynthian.sh
i noticed th following line:

creating alsa driver … hw:0|hw:0|1024|2|48000|0|0|nomon|swmeter|-|32bit
ALSA: Cannot open PCM device alsa_pcm for playback. Falling back to capture-only mode
JackTemporaryException : now quits…
Cannot initialize driver
JackServer::Open failed with -1
Failed to open server

The line “creating alsa driver…” does not showing my hw: setting for my soundcard.
so i did the following:

root@zynthian:~# eval dbus-launch --auto-syntax
root@zynthian:~# export DBUS_SESSION_BUS_PID DBUS_SESSION_BUS_ADDRESS
root@zynthian:~#jackd -v -R -P 70 -t 2000 -s -d alsa -d hw:CARD=ZEDi10 -r 48000 -p 256 -n 2 -X raw

now i start the ui in an different ssh window an the UI startet on the Monitor connected to the raspi

But not every time. I retried the steps for this posting and it does not work…
this is why nobody loves linux. Installing a usb soundcard which ist running with my ipad without drivers costs hours installing it under Linux.

OK. Next i rebooted the system. It came up with the error splash screen. I opend ssh and forgot to stop the zynthian service. i entered

root@zynthian:~# eval dbus-launch --auto-syntax
root@zynthian:~# export DBUS_SESSION_BUS_PID DBUS_SESSION_BUS_ADDRESS
root@zynthian:~#jackd -v -R -P 70 -t 2000 -s -d alsa -d hw:CARD=ZEDi10 -r 48000 -p 256 -n 2 -X raw

Ans the UI came up. I tested Audio and it worked.

maybe this helps. Beside my testing it would be nice to connect class-compliant usb soundcards. But i know the focus is with the integrated Hardware which is OK. If it works for me i will get the case and HiFiberry of course.

Now i need to try how my usb midi intefaces get to work.

Jens


#2

Hi @JayBee!

Try to configure the jack options in the webconf tool using the same values that worked for you in the command line. It should work.

Ahh! BTW, I really love Linux, my friend :wink:

Kind Regards,