Weird scenes inside the ZynSeq mine

Heya folks, I’m messing around with drums tonight. Before I tell a long tale, is there a way to switch the step editor in ZynSeq to a simple piano roll? How does it decide what layout to use?

Asking cause I’ve tried 808 samples on sfz and sf2, they sound great, but it’s showing the wrong labels on the notes, and it’s only showing some notes, so I can add them with the keyboard while doing a loop, but they don’t show in the interface for editing.

What version are you using? Testing? Stable?
Could you send some screenshots showing the problem?

BTW, pattern editor layout is selected based in the instrument name. Default is piano-roll, but the instrument have a specific layout, then it’s used. Perhaps the name of your soundfonts is creating. Try renaming them.


1 Like

In the pattern editor menu there is an option called, “Scale” which may be changed to select what notes are displayed.

It would be useful to konw what what instrument pack you are using so that we can add the correct midnam mapping.

Will follow up with specifics, it was late and I just wanted to register the weirdness. I’m still getting the hang of things with the many buttons and whatnot. I did figure out how to change the scale, but it was already set to Chromatic and it was not a piano roll, it was a bunch of white boxes with wrong names.

Will follow up as I said. My objective was to use some 808 samples internally rather than pull out my old drum machine. I’ve been focused completely on bands for years but musicians are flakes and I’m kinda done with em. I know piano now. :>

I’ve dug the occasional tunnel in this sort of direction and used the chromatic and scale features. I tend to keep Church bells in MIDI channel 11 for no better reason than it’s one more than ten.

This morning things went better for whatever reason, I tried the same thing I tried last night but everything seems to be working as it should now. I did run an update (stable) so who knows. :>