What does the USB-B port do?

So I speculated that the USB-B port (the large square one like you see on keyboard controllers and printers) might act like a USB sound or Midi interface on a PC, but I just plugged my V5 into my windows PC and it does not seem to appear as a sound device or a drive or a Midi device or anything.

So what’s that port on the back for?

It should appear as a MIDI device. Are you testing with stable, right?

If it doesn’t, you could check it’ the harness is well inserted in the mainboard, not reversed, etc.


I think I’m on testing at the moment actually, it’s been a minute since I updated and I’m thinking it’s time for a fresh reimaging anyways.

What I was mostly curious about was whether it functioned like a USB sound interface for a PC, cause that would be kinda cool. ;->

The USB type-B connector is attached to the RPi USB type-C connector. It exposes the Zynthian’s “Host Computer” MIDI port. Connecting this to a computer’s USB type-B (or type-C) port should present the computer as a MIDI port to Zynthian and Zynthian as a MIDI port to the computer. This is known as “gadget mode” or “On The Go” (OTG).

We do not support audio over this link (yet), only MIDI. We may investigate other options in the future. (Audio was not possible when we first implemented this feature and I don’t know if it is yet but either way, audio presents substantial challenges due to the way jackd work.)

In Oram this port will appear in the MIDI input/output lists only when the port is connected to a computer that has recognised it as a MIDI device. It will appear as “HOST USB MIDI”.

1 Like


On my system ( updated Oram yesterday on Pi5) the USB C port on the Pi appears as “MIDI function” on my PC apps (Ableton or Midi-ox) and comes and goes as expected when cable is inserted/removed. I have set a midi channel when creating the instrument chain but can neither send nor receive midi on that channel. I see that midi configuration process has changed and expect I am missing something to get the desired behavior though it could be something specifically related to using the USB C connector. Following the Oram testing guide (I think). BTW the same cabling worked fine on my V4 with the stock OS. Suggestions?

Follow up. I now note that there is no option for a USB device in the “Capture midi from” menu on the Zynthian with just the PC connected even though the PC and PC software recognizes that a USB midi device has been. if I plug a USB keyboard into a Zynthian USB port that option appears and works fine.

1 Like

I just pushed a fix for this. Please update an retest.

The USB-B/C connection may have changed for RPi5. I don’t have a RPi5 so cannot test this. Maybe @jofemodo might take a look, or at least add it to his list of RPi5 snagging issues. On Rpi4 this port appears as “ZYNTHIAN MIDI 1” to the host computer and “USB HOST” in the Zynthian MIDI input/output lists. I would not expect it to appear as “MIDI function”. That is old behaviour that should have changed which makes me wonder if this will work in RPi5.

1 Like

Looking forward to testing this out but I broke my pi5 trying to debug fan problem and it will be a week or so before I’ve got everything put back together…

Got the Pi5 up and running and no behavior change after doing update (about 5 min. ago). Still no USB showing in Capture MIDI from and Zynthian still showing up in Ableton as “MIDI function”.