WiFI interface not loading on Pi 3 B+


#1

Hi there,

I recently upgraded the Pi of my Zynthian build from a 2 B+ to a 3 B+ due to the low processing power of the 2 B+ causing issues with sampling software. This upgrade fixed that issue, however I am now having problems with WiFi connectivity.

On first boot using ethernet, I was able to access the web interface and set up WiFI. I then rebooted without ethernet to find that it was not online, and I could no longer access the web interface.

Booting it a third time, running ifconfig I found that the interface was not being recognised, even after setting the correct WiFi locale and trying to start WiFi from the admin menu of Zynthian.

I have also tried installing the packages suggested in this post with no luck:

apt install wpasupplicant firmware-brcm80211

In dmesg, we see an error -2 when loading the brcm firmware:

[    3.287408] brcmfmac: brcmf_fw_map_chip_to_name: using brcm/brcmfmac43455-sdio.bin for chip 0x004345(17221) rev 0x000006
[    3.289863] usbcore: registered new interface driver brcmfmac
[    3.324797] brcmfmac mmc1:0001:1: Direct firmware load for brcm/brcmfmac43455-sdio.bin failed with error -2

Any ideas?


#2

Have you installed from a clean image?


#3

Yes, rewrote the SD card with a fresh version of the same image before booting.


#4

What was the link of the image?
When you update twice, the network should work


#5

The image was downloaded from the software page of the wiki late last year.

However, I did forget you were supposed to update twice. I ran an update once yesterday, which completed in a matter of seconds without any sign of anything happening. Updating a second time, the wlan0 interface appeared. Also loving the ui changes :slight_smile:

Sorry for the ignorance there!

Cheers.


#6

I updated twice and in the end I saw a wlan0 and a wlan1 mentioned in etc/network/interfaces.
I commented out the lines for wlan1 but still got no ability to make an “X” for wifi.

So I ssh to the raspberry pi and cd to etc/wpa_supplicant and did

wpa_supplicant -iwlan0 -cwpa_supplicant.conf

this caused wpa_suppicant to be initialized and I got an ip address from my internet router.

So why does this work but it doesnt work through the zynthian ui?


#7

If you are using a clean Gorgona Omega SD image and you udpated succesfully to the last version, then WIFI should work OK after rebooting the machine. Of course, you still need to configure your WIFI networks from webconf tool.

Regards,


#8

you guys have fit a large amount of things onto this little raspberry, it’s pretty amazing.

I lost the thread of whether my wifi started working because I configured it correctly or because I commented out the wlan1 stuff? in any case it works now


#9

Hello @gminorcoles,

George, that is nice to hear. Now keep on making good music with less resources tweaking files.

Greetings and God bless, Marius