WIFI Issue with ARUK

Hello folks,

I flashed ARUK yesterday.

I could not activate the Wifi in the webconfig. I received the error message: "Can’t start WIFI network!

I tried to adjust the “wpa_supplicant.conf” via Putty and Kosole. It was actually Country=ES registered here. I changed it to Country=DE.

Now the following happens: If I save now and restart the zynthian the “wpa_supplicant.conf” is gone.

Only when I click on “Save Options” again in the webconfig of the Wifi settings the “wpa_supplicant.conf” is there again, but again with “Country=ES”.

Anyone got an idea how to get the Wifi running?

You should “Add” a wifi network before activating …

The wpa_supplicant.conf is now managed by Zynthian configuration system. If you want to modify it, you should modify this file:


instead that the one in /etc.

Regarding the country parameter, “ES” should work for Germany too, but i will add an extra field for configuring this from webconf.


I tested those three options today:
a) Home Wifi Router (ok)
b) Android Phone as hotspot (couldn’t connect)
c) Zynthian as hotspot and Android connected to it (ok)

1 Like