Wifi Setup Problem for Kit V4 [SOLVED!]


I’m having a problem to connect my Zynthian via wifi, I have tried:

  1. from the touch screen, I got this: STARTING WIFI ERROR / Can’t start WiFi network!

  2. I used the Ethernet RJ45 connector, it is fine to access webconf → system → wifi → Add Network → found my local wifi and add passwords, clicked “Save Options”, yet the WiFi access does not work properly for some reasons…

Could anyone guide me what may be the problem? Thanks!

My SD image is brand new from the last download link:

Hi, me again…

I got this solved by myself.

Here is my solutions in case you are having this similar problem:

  1. when your Zynthina is connected via the Ethernet, ssh into its system, or open webconf → system → Terminal

nano /zynthian/config/wpa_supplicant.conf

then you could see:

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev

Change “country=” according to your country code from this following list of codes:

For example, like me from China, then


and then the wifi should be fine to set up now, go to webconf → System → WiFi → Mode → On

btw, I updated timezone for my Zynthian’s system as well, it may or may not be relevant to this wifi problem, yet I did it anyway:

sudo apt-get install ntpdate

sudo ntpdate cn.pool.ntp.org
#cn.pool.ntp.org is for China,
#you need to check what is ntp for your coutry

#select your country step by step

sudo timedatectl set-ntp false
sudo timedatectl set-ntp True

#check if the time is updated and correct according to your country now

you needed to set wifi mode to ‘on’ in the webconf.