Win10 Zynthian USB driver error

Suddenly my USB midi connection to my PC has stopped working and is giving a Win driver error:

Windows has stopped this device because it has reported problems. (Code 43)

A request for the USB device descriptor failed.

Device USB\VID_0000&PID_0002\6&331d7093&0&3 was not migrated due to partial or ambiguous match.

Last Device Instance Id: USB\VID_0483&PID_5730\6&2c8caa37&0&1
Class Guid: {36fc9e60-c465-11cf-8056-444553540000}
Location Path:
Migration Rank: 0xF000FFFFFFFFF120
Present: false
Status: 0xC0000719

I have cleared all chains and tried omni and multi-chan mode with the same results. My current software is:
zyncoder: stable (89b1eb7)
zynthian-ui: stable (503aa74)
zynthian-sys: stable (d19e5b7)
zynthian-data: stable (9180393)
zynthian-webconf: stable (0c759b3)

Any suggestions on what to look for?

I guess you have connected the Zynthian’s power connector to your Windows PC’s USB port? It is likely that there is insufficient power available to drive the Zynthian. It may have been on the edge and something just pushed it over. How are you powering the Zynthian?

I have a Pi power supply connected through the special power/data Y cable that has been working without problem for several months. I replaced the Y connector, USB cable and moved to a different USB port and the problem did not go away. Everything else seems to be working (can add remove chains and it passes the “audio test”). I have not tried the DIN midi as it is physically difficult. Have just gone back to the Nov. release and the problem remains. Unfortunately, I just discovered that at some point system restore on my PC got disabled (nothing I did AFAIK) so I can’t go back to a previous version to see if it was some other software load that caused the problem. So blocked for the moment.

I can confirm this is not working currently. It seems to be a regression. g_midi driver is not being loaded and hence the OS does not know to bind its OTG interface as a MIDI device. Manually loading g_midi after boot makes it work, e.g. modprobe g_midi. I can’t see why the module is not being loaded.

1 Like

Hello @harrylnorris ,
I played around with the OTG USB port for a while. I ended up replacing it with rtpmidi connection. Just connect the Zynthian and the PC to the network switch (or switches on the same network). Or try QMidiNet.
My example of connections - Zynthian from scratch made by ToFFmashines - #43 by ToFF