ZynAddSubFX. No sound on RBPi Headphones

I have been playing Zynthian download on a naked Pi without any screen attached, what is called headless mode, so I am not familiar with what the pi shows on an attached screen. So I setup according to the instructions on this wiki page: Beginners Headless Zynthian Tutorial - ZynthianWiki

There is a section on that page, “configure the hardware”, where you need to select the soundcard. Did you select the Raspberry pi headphones there?

I hate to admit: I’m a GUI guy. I don’t like to mess with command line unless it’s to recover from a crash. I never met an OS I couldn’t crash. (My next RBPi project will probably be a multi-processor dedicated to the GIMP. For instance, I run Win10 on my main machine, and Debian Live from USB. (I used to run WinXP with dual boot SUSE, until the sound board went out.) The Debian runs the GIMP faster than Windows on the same hardware. But that’s a whole different thing.)

I’ve been checking out the Zynthian apps that have graphic interfaces, but there are some problems. Besides the one here with the ZynAddSubFX audio output, when I open Pd 48Presets the display is outsized from the normal RBPi screen and it hangs up and crashes. It seems to be a problem with the screen sizing.

I really want to use ZynAddSubFX , because of the philosophy of synthesis. I got a full Debian ARM7 to try out on the RBPi. I want to use the plain RBPi to control the Zynthian GUIs. When I crash Zynthian (Pd) and reinstall, the RBPi refuses to recognize the Zynth, and requires to delete the known_locations content to get into ssh -Y root@zynthian.local.

Great, I just booted the Zynth, and it lost Aeolus. Another reinstall… that’s what I get for fooling around.

Aeolus is a strange beast. It demands to use the first four layers and hence if you have already allocated any engine to any of these layers it will not appear in the list. I would love to see that resolved but it is a bit of a niche engine so hasn’t garnered the love and support of a wide audience to promote the issue. And it is only a minor quirk that is easily worked around by communication. I do love Aeolus for its authenticity but do not use it much.

Thanks for the info about Aeolus. I deleted the channels and it came right back. I love the pipe organ, having played in a few churches, although most have electronics like Allen, Baldwin, and Yamaha. The pipe organ is a completely different animal than the Hammond.

Next question: how do I get Aeolus to play all four MIDI channels simultaneously? I set up a Combi with upper split on 1 and 2, and lower split on 3 and 4, to correspond with the Aeolus I and II for right hand, and III and Pedal (mono, lowest note, pinky finger) for left hand. It would still only play one active channel and not mono the pedal.

Next question: Which method is best for using the GUIs, ssh or VNC or something else? I’d like to use a dedicated RBPi (Ethernet) for this. There’s no requirement for encryption.

1 Like

Vnc seems surprisingly efficient. Riban and I both acknowledged this during our recent moot.

It’s refreshing to communicate with you guys. I just spent a miserable day fighting with the latest Windows “upgrade.” They forced a new browser, Edge, and it caused both Chrome and Firefox screens to flash (lucky I’m not epileptic). It took an hour for “recovery” to run. I’ve seen worse, but this is the CamelsBack. How did they know that I was planning to try out a new Debian install on an RBPi? :roll_eyes:

1 Like

I run my desktop on a Pi 4 and I feel so much more in control than the Windows 10 PC I use elsewhere. I’m assured Mac’s are ‘better’ in this regard but I’ve not really missed anything specific, and with Microsoft contributing visual studio code to re join cross platform development we might be returning full circle !

To use that most modern of computing phrases ‘Cattle not Pets’, we probably sit on the edge of that relationship as what we are building round here are highly specific animalistic companions, it’s all quite touching really, but our relationship and responsibilities when we interact with the wider world is often confused by what commerce has done to the simple environment Tim Berners Lee put together all those years ago.

I wonder when the first integrated circuit came into my household? It was probably our first colour television; a dash of rtl in the selectors? a small amplifier for the speaker. . . .1972 . . ?

Now look around :smiley: but the actual interaction with the device takes many years to refine. It took us twenty years to accept that the light that came on when the TV was turned on should be green as it normally is nowadays from the Red! Danger!! our first colour tele displayed ! :slight_smile:

LOL! I remember our first remote control TV. It had servo motors to actually turn the knobs.

My first synth, a Maxi Korg, had ‘integrated’ circuit oscillators, roughly 6x6x2 cm, discrete components imbedded in epoxy.

My main concern is control surfaces. Once a musician has put in the years of work on a specific instrument, for instance, the piano, what would be the motivation or advantage of switching to a square grid?

There may be little incentive to change from the instrument you are familiar with but just because the piano has survived for hundreds of years doesn’t mean there are not other input methods that may suit modern instruments. I think there is room for all sorts of sound triggers and I am happy to be broken out of my keyboard or guitar constraints by some disruption that says, “Hey - try this way to control an instrument”. I was suprised with the interesting and unexpected results of playing a piano sound from a MIDI guitar and since have been open to trying anything - it doesn’t all make sense nor always work but its is worth trying something different. You may be pleased with the unexpected results. I guess I am saying that a pianist may always want to play a piano keyboard but they as well as non-keyboardists can benefit from alternatives. :grinning_face_with_smiling_eyes:

True, that. I was merely commenting on the amount of physical training required to gain skill on one instrument (the famous 10,000 hours). I have nothing against alternative control surfaces. In fact, I’m fascinated by the hexagonal grid that I saw in an old MagPi; it seems to be a one-of-a-kind instrument. And I fully intend to get a square grid controller for percussion programs, MIDI control, etc. I’d also like to have a MIDI guitar. I’d also like to have a tablet where I can write staff, print score, drive synths, and convert to MIDI. :wink:

And yet the original problem remains.

When I start zynaddsubfx I get this error:

Starting Audio: JACK
Jack buffer resized
Jack reports error: jack_port_get_buffer called with an incorrect port 0
Jack reports error: jack_port_get_buffer called with an incorrect port 0
Jack reports error: jack_port_get_buffer called with an incorrect port 0
Jack reports error: jack_port_get_buffer called with an incorrect port 0
Audio Started


When I start zynaddsubfx -a, it seems to be corrected:

Starting Audio: JACK
Jack buffer resized
Audio Started

The GUI screen:

Notice the :warning: in the upper right corner. Something is still not right. The RBPi Headphones are active, ZynAddSubFX is set on MIDI channel 1, and the DJ equalizer is active. When a key on the virtual keyboard is pressed, the output meter shows output, but there’s still no sound in the phones.

Will another -switch fix this?

Hi @mickey !

Could you send a screenshot from your webconf dashboard?
Are you using the RBPi Headphones as main output or simply “enabled” the Headphones option from the Admin menu? If you disable it, does it work?


Here’s a fresh screenshot:

Yes, the RBPi headphones are the only output, no other connections except Ethernet to another RBPi. (I’m listening to the Test Audio right now.) Audio stops when the headphones are disabled, comes back when enabled again.

I’ll try again later with full audio and MIDI hooked up–got to move a lot of stuff around to do that…

Right now I’m fighting a Windows update that caused the screen on my laptop to flash. Wasted 1/3 of the month’s data reloading the update, and it’s still not fixed. They force all of this bloatware, and then it doesn’t even work.

1 Like

I feel your pain (at work)

1 Like


OK, I had a NOOBS card that I bought (I won’t say the vendor), but it was old. So I had downloaded a new NOOBS from the RBPi official site, but it wouldn’t boot. I tried burning the SD with Win10, Debian, and Raspbian, but NOO! Obviously, there was something wrong with the download. So I downloaded the newest full version (from the RBPi official site), and it worked perfectly! Lots more software, too.

If you re-install either the Raspbian or the Zynthian OSes, the Raspbian SSH won’t recognize the Zynthian. Go into the Raspbian File Manager and set it to show hidden files, go into the .ssh folder and open the text file, delete the hash numbers, and save the empty file. This will force the RBPi to recognize the Zynthian.

Otherwise, I’ve been figuring out how to drive multiple MIDI channels from the old TRITON. I haven’t figured out how to force the Zynth to recognize lowest note mono yet; is this possible?

1 Like

Each engine behaves differently. Is it ZynAddSubFX you want this behaviour?

It’s Aeolus, at first…left hand playing a chord as on manual III, with only the lowest note playing pedal, and right hand playing melody on manual I or II. Since Aeolus grabs the first 4 MIDI channels, it would be good to experiment with various control settings.

There are so many functions on the Zynthian, it’ll take some time just to check them all out.

It sounds like quite a specific use case. You want the left hand chord to play on manual 3 and lowest note of that cord to play pedal. You can set up a keyboard split to give left / right hand but maybe a filter / plugin is required for the pedal bit.

[Edit] I was just looking at Moony LV2 plugin that is in Zynthian. (I never noticed this before!) It allows you to script the handling of events in LUA. The GUI accessible via VNC presents a code editor. I would guess this would be a way to configure a plugin to only sound the lowest note. I am not familiar with LUA and am off for dinner now so haven’t looked how to do it specifically.

Yes, that’s exactly what I want, and have already set up on the old TRITON. My original Combi (for live performance) was all internal MIDI, so I changed to EXT 2 and assigned the channels to 1-4, as required by Aeolus. The Pedal plays polyphonically. Then, if I set mono, it goes to top note priority, instead of low note. I’ll keep on until I figure it out. This works when other synths are assigned to the channels, as well, but the top note priority remains.

I haven’t seen the Moony LV2 yet. I’ll check it out.

BTW, I’ve been following Accessibility for sight impaired users
(I read a lot.) Lewis is a hero, he needs a new Kurzweil (the engineer, not the instrument). My problems are rather insignificant in this light.

I have a slab piano that I need to repair (got the contact strip), and some nature videos to score (involuntary ornithology).


The slab piano is fixed. Viola C was stuck on LOUD, with no touch control.

The nature videos were in progress, but the latest Mothersoft update deprecated the video editor, not to mention forcing another web browser on us. I had enough. So, I wiped my windows and did a full Debian installation/migration. Not completed yet, but all the major software is there–it comes with the OS, whooda thunkit?

Strange Days have found us, we have a plague of scorpions, and they just keep getting bigger.